Moz breaks Yahoo email sign-up form

RESOLVED DUPLICATE of bug 198433

Status

Tech Evangelism Graveyard
English US
RESOLVED DUPLICATE of bug 198433
15 years ago
3 years ago

People

(Reporter: Jim Avera, Assigned: Susie Wyshak)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030315
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030315

It is impossible to sign up for a new Yahoo email account using Mozilla
because a drow-down menu in the sign-up form doesn't work under Moz.
(but does work with Netscape 4.7x).

In the Yahoo e-mail account sign-up (see URL above), the drop-down
menu for "Title" does not contain any entries when viewed with Mozilla,
so no value can be specified.  Under Netscape 4.7x there are many
entries (depending on what you put into "Industry").

Unfortunately, "Title" is a REQUIRED field, and yahoo will not
accept the registration unless it is set...

Reproducible: Always

Steps to Reproduce:
1. Go to Yahoo Email new-account sign-up page (URL above)
2. Enter name, etc. (maybe unnecessary) 
   For "Industry", select 'Other'.
3. Attempt to set "Title" - no items appear in the drop-down menu.

Actual Results:  
The "Title" drop-down menu has no entries, so nothing can 
be selected.  When you click Submit, Yahoo refuses to accept
the registration.


Using Netscape 4.7x to register is a work-around.
The page tries to set the "text" property of a HTMLOptionElement.  In NS4, this
property seems to be writable.  In the DOM specification, it is defined to be
readonly.  So Mozilla throws a "attempting to set readonly property" exception.

The DOM spec is a Recommendation and this is a frozen interface, so it is not
changing...
Assignee: asa → susiew
Status: UNCONFIRMED → NEW
Component: Browser-General → US General
Ever confirmed: true
OS: Linux → All
Product: Browser → Tech Evangelism
QA Contact: asa → zach
Hardware: PC → All
Version: Trunk → unspecified
Well... Looks like there's an interface hack that was supposed to make this not
happen, but it was done wrong....

*** This bug has been marked as a duplicate of 198433 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.