Animated gifs intermittently disappear, get replaced with image name

VERIFIED DUPLICATE of bug 6525

Status

()

Core
ImageLib
P3
normal
VERIFIED DUPLICATE of bug 6525
19 years ago
19 years ago

People

(Reporter: Tom 7, Assigned: pnunn)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The animated gifs on the included URL intermittently disappear after an
indeterminate number of iterations in M11. This also appears to happen
intermittently upon some other events, such as when you click on one (they are
links) -- the lossage is visible before the destination page loads.

Indeed, if one does a "view image" on one of the gifs (I've attached one here),
it turns into a text url after around 2 minutes. HOWEVER, this doesn't appear to
happen if the file is viewed from the local disk (though I can't verify whether
if *ever* happens)...

Perhaps this is related to the other animated gif bugs, but I didn't see any
describing this problem in particular.

FYI, these gifs were compressed with "A Smaller Gif" and work fine in
NS4/IE/other gif viewers.

Build: M11 (have noticed problem with previous builds too)
Build ID: 1999111520
(Reporter)

Comment 1

19 years ago
Created attachment 3008 [details]
Test Animated GIF from page

Updated

19 years ago
Assignee: leger → pnunn
Component: Browser-General → ImageLib
QA Contact: leger → elig

Comment 2

19 years ago
Moving to ImageLib; this is most likely a duplicate of several known bugs
relating to images halting after 10-30 minutes as a result of a memory leak.

Comment 3

19 years ago
Thanks, by the way, for the detailed bug report with the minimized test case.
(CMU rules. ;)
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13
(Assignee)

Comment 4

19 years ago
Eli: this doesn't look like a manifestation of the mem leak
stuff to me. I'm seeing some mime type bugs show up. This may
be a duplicate of one I'm looking at now. I'll take the bug
and reassign as needed.
-pn
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
will add test url to 6525.
-pn

*** This bug has been marked as a duplicate of 6525 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Rubber-stamping as duplicate; will double-check this bug when 19845 is verified.

Comment 7

19 years ago
Doh, I mean when 6525 is verified.
You need to log in before you can comment on or make changes to this bug.