The default bug view has changed. See this FAQ.

float:right objects misplaced when in a position:absolute environment

RESOLVED FIXED in mozilla1.4alpha

Status

()

Core
Layout: Floats
P1
normal
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Christian Eyrich, Assigned: dbaron)

Tracking

Trunk
mozilla1.4alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch])

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux y686; de-DE; rv:1.4a) Gecko/2003032011
Build Identifier: Mozilla/5.0 (X11; U; Linux y686; de-DE; rv:1.4a) Gecko/2003032011

Using position:relative for the wrapping div paints the "right" box where it is
in the code: at the top right beside the "Hello,". Using position:absolute pulls
it down to the height of the "left" box.

Mozilla changed behaviour with build 2003031204 – builds before (testet
2003031104) put the "right" box in the upper right corner even with
position:absolute.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 117917 [details]
Testcase to show the bug
(Assignee)

Comment 2

14 years ago
It's clear the problem is that there's an extra reflow happening without a
PushState/PopState on the space manager.  The question is why.
(Assignee)

Comment 3

14 years ago
The problem is the extra call to ReflowDirtyLines on nsBlockFrame.cpp, line
1396, in nsBlockFrame::ComputeFinalSize.  (Why do we have so many different ways
of shrink-wrapping?)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

14 years ago
Created attachment 117948 [details] [diff] [review]
patch

This was a regression from bug 196919 (as I expected).	The caller where the
problem is is the only caller of ClearRegions.
(Assignee)

Updated

14 years ago
Attachment #117948 - Flags: superreview?(roc+moz)
Attachment #117948 - Flags: review?(roc+moz)
(Assignee)

Comment 5

14 years ago
Taking.
Assignee: float → dbaron
Priority: -- → P1
Hardware: PC → All
Whiteboard: [patch]
Target Milestone: --- → mozilla1.4alpha
Comment on attachment 117948 [details] [diff] [review]
patch

Easy one!
Attachment #117948 - Flags: superreview?(roc+moz)
Attachment #117948 - Flags: superreview+
Attachment #117948 - Flags: review?(roc+moz)
Attachment #117948 - Flags: review+
(Assignee)

Comment 7

14 years ago
Fix checked in to trunk, 2003-03-20 19:11 PST.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

14 years ago
Thanks for noticing the bug.  (Should be fixed in today's build.)
(Reporter)

Comment 9

14 years ago
Just checked today's build.
Bugfixing at hyperspeed - that's great!
You need to log in before you can comment on or make changes to this bug.