Add card in a Mozilla address book, delete Palm category and Palm wins

RESOLVED WONTFIX

Status

MailNews Core Graveyard
Palm Sync
RESOLVED WONTFIX
15 years ago
4 years ago

People

(Reporter: Ninoschka Baca, Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss

Details

(Reporter)

Description

15 years ago
Trunk build 2003-03-20: WinXP

Overview: In a Mozilla address book, add a new card. On the Palm device delete
the corresponding category, hotsync and the address book/category does not apear
on either side.


Steps to reproduce:
1. In Mozilla create an address book, add some cards, hotsync so now it appears
on the Palm device as well (i.e. AB1)
2. In Mozilla add a new card
3. On the palm device delete the corresponding address book (i.e. AB1)
4. HotSync

Actual Results: The address book and its cards are deleted from Mozilla and also
do not appear on the Palm device.

(2nd scenario: I also tried renaming the Mozilla address book:
Rename a Mozilla address book and add a new card. On the Palm device delete the
corresponding category, hot sync and the address book/category does not appear
on either side.)

Expected Results: Since a new card was added in the Mozilla AB I would expect
the address book and its cards to remain on both sides to avoid data loss.
(Reporter)

Comment 1

15 years ago
Marking nsbeta1 to consider fixing for this release.
Assignee: rdayal → cavin
Keywords: dataloss, nsbeta1

Comment 2

15 years ago
Mail triage team: need info.  Does the personal address book go away or is it a
special address book that doesn't?
Whiteboard: [need info]
(Reporter)

Comment 3

15 years ago
Trunk build 2003-03-27: WinXP
- If the PAB is deleted from the palm device then the PAB in Mozilla is never
removed and doesn't appear on the palm device after the 1st hotsync. Upon the
2nd hotsync then the PAB and its contents reappear on the palm device.

- The same is true for the CAB

- For user defined address books, these are the ones that are affected.
Mail triage: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Whiteboard: [need info]
Product: MailNews → Core
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
Assignee: cavin → nobody
QA Contact: nbaca → palmsync

Updated

9 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.