Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.hostPort]

VERIFIED DUPLICATE of bug 195833

Status

()

VERIFIED DUPLICATE of bug 195833
16 years ago
16 years ago

People

(Reporter: mks, Assigned: rogerl)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If you play the WordWiggle game and just pick some letters to form a word and
then press the "Keep" button, an error shows up in the JavaScript console that
did not show up before I switched to Mozilla 1.3 and, as far as I can tell,
should not be happening:

Error: [Exception... "Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [nsIURI.hostPort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"
 location: "JS frame :: chrome://navigator/content/nsBrowserStatusHandler.js ::
anonymous :: line 350"  data: no]
Source File: chrome://navigator/content/nsBrowserStatusHandler.js
Line: 350

I am fairly sure that the JavaScript on the web site is not directly at fault. 
At least it does not seem to cause this problem elsewhere, including in earlier
Mozilla versions, IE, or other browsers that I have tested.

NOTE - you do not need to register at the site to play the basic parts but
registration is just so that the games can be tracked and if need be I can clean
out any registrations after you have tested it.

Also, I am not sure that this is a JavaScript engine bug - however, I can not
seem for find a better component to put this under so for now it is here.
> I am fairly sure that the JavaScript on the web site is not directly at fault. 

Indeed.  This was an error in JS code internal to Mozilla.

*** This bug has been marked as a duplicate of 195833 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified Duplicate.

Michael: thank you for this report. The fix for bug 195833 was
checked in on March 6. Any Mozilla build dated March 7 or after
should be free of this error. 

If not, please reopen bug 195833. If that requires a Bugzilla
account, see http://bugzilla.mozilla.org/createaccount.cgi
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.