focus is stolen from input field when multiple browser tabs are opened at once

VERIFIED DUPLICATE of bug 124750

Status

SeaMonkey
Tabbed Browser
VERIFIED DUPLICATE of bug 124750
16 years ago
10 years ago

People

(Reporter: Lutz Hoeger, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

When opening multiple tabs at once, which contain pages with input fields, the
cursor get's 'stolen' from the input fields of the currently displayed tab and
is set into input fields of another page from the group. 

Reproducible: Always

Steps to Reproduce:
1. Define a home page group, consisting of a bnalnk page and several pages that
contain input fields
2. load the group at once (by selecting "Go - Home" or pressing Alt-Home)
3. While some of the pages are still loading, go to one that has completed
loading and type into the input fields.

Actual Results:  
The cursor is being 'stolen' from the current page and input field, and even
worse: being set into an input field on a tab that's currently not visible! Of
course everything I type (name, password) then goes into the second page! It
shows up as soon as I switch to that page.

Expected Results:  
Keep the cursor focus on the currently displayed tab, no matter of the source
code of pages that are loaded in other than the active tab. If pages on
non-active tabs e.g. set the focus to an input field via Javascript (I don't
know if this is possible), this shouldn't affect the cursor focus on the
currently active tab.

Comment 1

16 years ago
<body ... onLoad="window.document.formular.query.focus()">
Dupe of bug 124750

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 124750 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.