Highlighted buttons within forms don't highlight correctly

RESOLVED DUPLICATE of bug 197094

Status

Camino Graveyard
HTML Form Controls
--
trivial
RESOLVED DUPLICATE of bug 197094
15 years ago
15 years ago

People

(Reporter: TGOS, Assigned: Brian Ryner (not reading))

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030320 Chimera/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030320 Chimera/0.7+

If you press the button of a form, it won't highlight correctly. The problem
appeared for the first time after Camino temporarily used non-Aqua widgets in a
nightly build. The following nightlies were all broken and the first nightly
that was working again already had this bug. It only applys to form buttons.
Buttons of Javascript pop-ups or buttons that belong to the browser GUI render
correctly.

Reproducible: Always

Steps to Reproduce:
1. Press a button

Actual Results:  
The button gets blue, but has a strange white gray stripe in the middle (which
stays there, even if you release the button)

Expected Results:  
Render form buttons like the other buttons.

Despite the incorrect (and butt ugly rendering), the button still works though.
(Reporter)

Comment 1

15 years ago
Created attachment 117990 [details]
Screenshot of a pressed button

Here's a screenshot to show you the problem.

Comment 2

15 years ago
This is a dup of Bug #197094 (I don't have sufficient privileges to close this).
(Assignee)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 197094 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.