HTMLArea Editor does not work with Mozilla 1.3 Release or Nightly

RESOLVED DUPLICATE of bug 198036

Status

()

--
major
RESOLVED DUPLICATE of bug 198036
16 years ago
5 years ago

People

(Reporter: mtearle, Assigned: Brade)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030318
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030318

HTMLArea does not work on:

 Mozilla 1.3 Release, Mozilla Nightly on MacOS X
 Mozilla CVS Snapshot (1.4a) on Debian Linux

although does work on:
 Mozilla 1.3b MacOS X and Debian Linux
 Mozilla 1.3 Release Redhat Linux

Javascript console reports:

Error: [Exception... "Component returned failure code: 0xfeedbeef
[nsIDOMNSHTMLDocument.execCommand]"  nsresult: "0xfeedbeef (<unknown>)" 
location: "JS frame ::
http://www.interactivetools.com/staff/ben/htmlarea3_demo/htmlarea.js ::
anonymous :: line 870"  data: no]
Source File: http://www.interactivetools.com/staff/ben/htmlarea3_demo/htmlarea.js
Line: 870

Reproducible: Always

Steps to Reproduce:
1. Go to supplied URL

2. Attempt to bold a selection of text
3.

Actual Results:  
Nothing, error message in Javascript Console

Expected Results:  
Text should have been made bold

Comment 1

16 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030317

Went to suplied URL, selected "Different fonts, sizes and colors (all in bold):"
and changed to bold, italic, underlined and combinations thereof.
Whiteboard: DUPEME

Comment 2

16 years ago
Giving to brade ... not sure if this is happening because of bug 198036, which 
was fixed already.
Assignee: jfrancis → brade
(Assignee)

Comment 3

16 years ago
This is probably a duplicate of 198036 (and a few other bugs).  Please
retest with a newer build (fix was checked in just after 3/18 builds were
produced).  It works fine on my debug macho build from yesterday.

*** This bug has been marked as a duplicate of 198036 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Tested, working on Mac OS X with Mozilla Nightly Build 2003032108.  Thanks! 

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.