Blank mail headers and new mail window in localize build

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: p.franc, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.3) Gecko/20030312

After creating czech instaler for Windows using mozip.exe and standard procedure,
the instaled Mozilla mail doesn't display mail headers and mails in new window.

Czech language package is correct since installed english buil with the same
czech added is working fine.

Reproducible: Always

Steps to Reproduce:
1.Create localize build
2.Install it
3.Run Mozilla mail&news




JS console
----------
Error: uncaught exception: [Exception... "Component returned failure code: 
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult: 
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: 
chrome://messenger/content/msgHdrViewOverlay.js :: OnLoadMsgHeaderPane :: 
line 214"  data: no]
-----------

and here is the line (marked by *) which produce this error

--------
gNumAddressesToShow = pref.getIntPref("mailnews.max_header_display_length");
gCollectIncoming = pref.getBoolPref("mail.collect_email_address_incoming");
gCollectNewsgroup = pref.getBoolPref("mail.collect_email_address_newsgroup");
gCollectOutgoing = pref.getBoolPref("mail.collect_email_address_outgoing");

*  gShowUserAgent = pref.getBoolPref("mailnews.headers.showUserAgent");  

gShowOrganization = pref.getBoolPref("mailnews.headers.showOrganization");
--------

weird thing is that according about:config these preferences are set.
Temporary work around is replace

gShowOrganization = pref.getBoolPref("mailnews.headers.showOrganization");
gShowUserAgent = pref.getBoolPref("mailnews.headers.showUserAgent");

with

gShowOrganization = true;
gShowUserAgent = true;


This bug is a blocker for Czech Mozilla 1.3 Release.
Hi I am coleague of Pawell, I am looking for mailnews.js and we have it in our
installation.
It was prepared by our coleague which is currently on hollydays. And I thing the
problem is our mailnews.js in $MOZILLA/defaults/pref/ folder. Because when it is
replaced by mailnews.js file from original Mozilla instalator, this problem is
solved.

I am sending our "problematic" file as attachement.
Created attachment 118007 [details]
File from czech Mozilla installation in wich is probably the problem

File from czech Mozilla installation in wich is probably the problem
(Reporter)

Comment 4

16 years ago
The idea was correct. One line of mailnews.js was missing. Unfortunately JS
console poined out the wrong line since the missing preference  was the next one
which confused us a lot. 

However this disclose some weaknes of  msgHdrViewOverlay.js code
since it reads preferences without any try-catch approach.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.