odd triple click required to select all in url bar

RESOLVED DUPLICATE of bug 197613

Status

RESOLVED DUPLICATE of bug 197613
16 years ago
11 years ago

People

(Reporter: abwillis1, Assigned: hewitt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3) Gecko/20030313
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.3) Gecko/20030313

Starting I think with 1.3b and still exhibited in the release version if you
double click in the url bar puts the cursor at the end as I would expect.  If I
double click I would then expect it to hightlight the whole url (always has) but
now it just highlights the slash at the end.  Experimenting we found that if you
in essence do a "triple click" it will highlight the whole url.  It is a most
bizarre bug and I was surprised not to see a whole slew of reports on it.  There
are 5 or 6 of us who have seen this.  It works as expected on my OS/2 box but
when I have to use the w2k box it is most frustrating.  It is even more
frustrating to those who use w2k all the time.  Same behavior on XP box.  

Reproducible: Always

Steps to Reproduce:
1.  Click on url bar
2.  Double click on url bar.
3.  Triple click on url bar.
(Reporter)

Comment 1

16 years ago
First click should be single click in url bar puts cursor at the end as I would
expect.

Comment 2

16 years ago
This is by deliberate design.  See bug 197613

*** This bug has been marked as a duplicate of 197613 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.