Copy/Paste from View (Message) Source inserts spurious blank lines

RESOLVED DUPLICATE of bug 198391

Status

Core Graveyard
View Source
RESOLVED DUPLICATE of bug 198391
15 years ago
8 years ago

People

(Reporter: Norman Megill, Assigned: Doron Rosenberg (IBM))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

When copying from View Message Source, then pasting into a text editor,
blank lines sometimes get inserted, even though they don't show on the
View Message Source screen.  A strange sensitivity to a certain pattern
of ampersands causes this to happen.  I discovered the problem after
in-line LaTeX files sent to me, which I copied from the Message Source, were
occasionally corrupted.  My expectation was that the Message Source
would be the raw unformatted POP3 feed coming into mailer, which is not
quite the case due to this problem.  I found a simple test case that
reproduces the problem.

Reproducible: Always

Steps to Reproduce:
1. Email to yourself a plain-text message with several dozen lines, each
containing exactly three ampersands and no spaces:

&&&
&&&
&&&
&&&
&&&
etc.

2. When the message is received, View Message Source, and select and
copy these lines from the message source.  (They look normal at this point.)

3. Paste the lines into vi, Notepad, etc.
Actual Results:  
When pasted, a spurious blank line will be inserted in the text editor
between lines 4 and 5, then between 10 and 11, 16 and 17, etc. repeating
every 6 lines.


Expected Results:  
The lines should paste contiguously, with no spurious blank lines inserted.

Comment 1

15 years ago
I don't think this is mail-specific, I just found the problem in regular View
Source.  It does seem to happen after patterns, though.  I noticed it on a
Bugzilla entry.  Look for the section of HTML where the CC's are listed.  Copy
and paste this section and you'll see extra an extra blank line for each six
<option>s  If you cut and paste other sections, you'll see the same pattern, but
not for every six lines, for every six like /elements/ (try cutting the
component section instead).  This is very strange.
Assignee: sspitzer → doron
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → ViewSource
Ever confirmed: true
Product: MailNews → Browser
QA Contact: esther → pmac
Summary: Copy/Paste from View Message Source inserts spurious blank lines → Copy/Paste from View (Message) Source inserts spurious blank lines

Updated

15 years ago
Component: ViewSource → Accessibility APIs

Comment 2

15 years ago
Sorry for the multiple changes... darn bug 165836...
Component: Accessibility APIs → ViewSource
Product: Browser → Seamonkey

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 198391 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: View Source → View Source
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.