Highlighting not working in many places.

VERIFIED DUPLICATE of bug 198653

Status

SeaMonkey
General
--
major
VERIFIED DUPLICATE of bug 198653
15 years ago
13 years ago

People

(Reporter: Ray Trent, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030321
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030321

In the latest nightly (2003032108), many of the widgets (mostly tree and list
controls) are not showing the selected entry as highlighted.

E.g. In mailnews, the folder tree view and message listview both do not show the
selected item. 

Also in mailnews, the junkmail icon is not appearing on my junk folder. 

In the browser, the address bar dropdown is not highlighting the currently
selected item. However, this control is something of an exception. For this
control only, if I click on the down arrow first, then use the keyboard to
navigate the box, the highlighting works. Only navigating to the control
entirely via the keyboard fails for this control.

The sidebar treeviews are also broken.

This bug might possibly be a duplicate of bug 198642, but is much more widely
spread than what is reported there. 


Reproducible: Always

Steps to Reproduce:
Example:
1. Open MailNews
2. Select a folder
3. Select a message in that folder

Actual Results:  
The folder is not highlighted in step 2. The message is not highlighted in step 3. 


I also had a crash in XPCOM just after install, which I had to step through in
the debugger in order to get Moz to start the first time. I haven't checked yet
whether this is repeatable, but will report it if so. 

Also, I did an uninstall of the previous version first (though I didn't clean my
user profile except for XUL.mfl which I deleted once observing this problem, but
that didn't make any difference).

Comment 1

15 years ago
reassigning to seth per seth
Assignee: asa → sspitzer

Comment 2

15 years ago
dup of bug 198653?

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 198653 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.