Importing bookmarks should allow you to import into a particular folder

RESOLVED DUPLICATE of bug 137568

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 137568
15 years ago
13 years ago

People

(Reporter: Hoss, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2.1) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2.1) Gecko/20021212

Currently, when importing Bookmarks, the folders/bookmarks are imported into the
"top level" of your existing bookmark heirarchy.

I propose that when doing an import, you should be able to import into an
existing  "folder".  This could be implimented by assuming that if a folder is
both selected and "expanded" in the Bookmarks Manager, that the user wants to
import into that folder -- a "Warning" dialog box could ask them to confirm this.  

Another way to impliment this would be with options to the proposed
"Import/Export Wizard" of bug#76909, ie...
      x  Import into Top Level
      o  Import into New Folder
      o  Import into Existing Folder
... with the subsequent screen asking the user to select a folder for the second
and third options.

(There are lots of UIs this feature could have, My main point is that it should
be some way to do this.)


Reproducible: Always

Steps to Reproduce:




Deciding if/how to make this an option would probably depend heavily on
bug#45577 (import should merge folder contents ...)

Comment 1

15 years ago
dup of bug 137568

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 137568 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.