CRAM-MD5 authentication apparently not functional.

RESOLVED DUPLICATE of bug 41594

Status

RESOLVED DUPLICATE of bug 41594
16 years ago
10 years ago

People

(Reporter: mmqq, Assigned: Bienvenu)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030321
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030321

I've heard that recent versions of Mozilla's IMAP client can handle CRAM-MD5
authenticatiog.  Grepping through the source I find mention of CRAM-MD5 in the
IMAP-related code, but it appears to not be working.  If I login to my IMAP
server with Mozilla, it still uses the LOGIN or PLAIN methods, even if I disable
all mechs except CRAM-MD5.


Reproducible: Always

Steps to Reproduce:
1. Login to IMAP server offering CRAM-MD5 authentication.
2. Client attempts LOGIN (or PLAIN) authentication instead of CRAM-MD5.
3.

Actual Results:  
If I use PLAIN or LOGIN, I can login.  Otherwise, authentication fails.


Expected Results:  
Noticed that the IMAP server said this:

* CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT
THREAD=REFERENCES SORT QUOTA AUTH=CRAM-MD5 IDLE

and used CRAM-MD5.


I'd also _love_ to see DIGEST-MD5 implemented.
(Assignee)

Comment 1

16 years ago
I don't believe CRAM-MD5 has ever been turned on, despite what you've heard. If
you looked a little more closely at the code, you'd see that the cram-md5 stuff
is #if 0'd out - I don't know why, since I didn't put in the #if 0 code.
(Reporter)

Comment 2

16 years ago
Looks like it might work as well after uncommenting those lines, but we seem to
be missing "nsIHashAlgorithm.h"
It would be fantastic if we could get this functional.


(Assignee)

Comment 3

16 years ago
please see bug 41594

*** This bug has been marked as a duplicate of 41594 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.