CTRL-W doesn't work on "empty tab" to close window

VERIFIED DUPLICATE of bug 112337

Status

VERIFIED DUPLICATE of bug 112337
16 years ago
10 years ago

People

(Reporter: dcorbin, Assigned: jag-mozilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030305
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030305

When a URL is inaccessible, an "empty tab" created.  There "page" shows as a big
gray area.  From this tab, CTRL-W does NOT close the tab.  Click on the "X" icon
in the tab row, or selecting "File-Close Tab" does work.

Reproducible: Always

Steps to Reproduce:
1. Type in a url that does not exist.
2. Press CTRL-ENTER, to open a new tab.
3. Close the message box saying the URL could not be opened
4. Press CTRL-W.

Actual Results:  
Nothing happens.

Expected Results:  
The tab titled "(Untitled)" should be gone.

Comment 1

16 years ago
Your build is too old to report bug. Can you download a younger nightly, install
it cleanly and see if the bug is still alive ?

As it is written in red here : http://bugzilla.mozilla.org/enter_bug.cgi

"Also, please do not file bugs on copies of Mozilla older than two weeks."

Thanks.
Frederick, sorry, but the 2-week thing is ridiculous.  The build is being
reported with something _newer_ than our latest release.  Yes, it's not today's
nightly, but that's life.

And since I see this all the time in current nightlies on Linux too, I'm
confirming it.

aaronl, should this be yours?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
What is the window manager that you use? Some Moz shortcuts are taken over by
the window manager. For instance my KDE3.1 uses CTRL-TAB to run through my
different desktops, and therefore breaks the Moz functionality of running trough
different tabs.

Perhaps you can try figuring out if CTRL-W is reserved by your distro for other
purposes

Comment 4

16 years ago
Sorry. I won't touch anymore linux related bugs :-)
Ctrl-w works fine in all cases but that described in comment 0 for me.

Comment 6

16 years ago
this seems just like another dup of Bug 112337.
Ah, indeed.  I'd thought aaronl had fixed this.... and it had regressed...

*** This bug has been marked as a duplicate of 112337 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
v.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.