Sending text-only mail skips some line-ends

RESOLVED DUPLICATE of bug 125928

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 125928
15 years ago
14 years ago

People

(Reporter: panu, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

The following excerpt from mail was sent with a line-end
after the words 'and as'. Viewing the received mail
lacks it. *Some* preformatted lines are screwed up/concatenated:
---------------------
Now I think I've come about a succinct rule-of-thumb
definition, which higlights their difference, and as a bonus, exposes their dual
nature:

COMPOSITION means the parts can not exist without the whole.


Reproducible: Always

Steps to Reproduce:
1. Compose mail with several short (~40 chars) lines
2. Choose Options->Format->'Plain Text only'
3. Select all text and choose 'Format->remove all text-styles'
4. Send the mail to yourself or a newsgroup
5. When reading the mail, some lines that were separate
   in the original have been concatenated. Not all though
Actual Results:  
The received mail read:
---
Now I think I've come about a succinct rule-of-thumb
definition, which higlights their difference, and as a bonus, exposes their dual
nature:

----

Expected Results:  
The received mail should have been:
---
Now I think I've come about a succinct rule-of-thumb
definition, which higlights their difference, and as 
a bonus, exposes their dual nature:

--


This has happened several times with other emails
& postings to newsgroups. 

It really means I can't use Mozilla as an email-client
as it screws up my formatting

Comment 1

15 years ago
Reporter: are you using the plain-text or HTML editor to compose your email?
If HTML, I believe you are seeing bug 125928.

Comment 2

15 years ago
No response from reporter, duping.

*** This bug has been marked as a duplicate of 125928 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.