inlines wrapping around floats only check top pixel of line for overlap

RESOLVED DUPLICATE of bug 25888

Status

()

Core
Layout: Floats
P1
major
RESOLVED DUPLICATE of bug 25888
15 years ago
15 years ago

People

(Reporter: Ben Morrow, Unassigned)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

When wrapping inline text around a series of floats arranged vertically by using
float: left and clear: left on each, a line of text is only broken if it's
top-left pixel would overlap with the float. What should happen is both the
top-left and bottom-left pixels should be checked.

Reproducible: Always

Steps to Reproduce:
1. Open the following attachment.
Actual Results:  
Above the line, where the top pixel of the first line of text is aligned with
the top pixel of the float, the text correctly wraps round the float. Below the
line, the small image causes the large image to start part-way down the first
line of text, which thus wraps incorrectly and overlaps the larger image.

Expected Results:  
Both sets of text should have wrapped in the same way: there should have been no
overlap.
(Reporter)

Comment 1

15 years ago
Created attachment 118162 [details]
HTML testcase demonstrating the problem

This is explained in the initial report.

Comment 2

15 years ago
I see this too LInux 2003032108
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
*** Bug 192415 has been marked as a duplicate of this bug. ***
Summary: inline-mode boxes wrapping around floats with clear: set only check the top pixel of each line for overlap → inlines wrapping around floats only check top pixel of line for overlap

Updated

15 years ago
Target Milestone: --- → Future

*** This bug has been marked as a duplicate of 25888 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.