bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th from 16:00 until 20:00 UTC.


Download & File Handling
15 years ago
11 years ago


(Reporter: Sobrinho, Unassigned)


Firefox Tracking Flags

(Not tracked)




(3 attachments)



15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020919 Debian/1.1-1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020919 Debian/1.1-1

when download this file, in the progress the time remaining is negative number

Reproducible: Always

Steps to Reproduce:
1.download this file http://www.swift-tools.com/Flash/flash-0.4.10.tgz

Actual Results:  
progress time is wrong

Expected Results:  
progress time is rigth

Comment 1

15 years ago
Created attachment 118184 [details]
Wrong progress

Comment 2

15 years ago
1.1 is too old, upgrade to 1.3 and reopen if bug still occurs.
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
build ID 2003032305
see new attach!
Resolution: INVALID → ---

Comment 4

15 years ago
Created attachment 118256 [details]
Wrong time in Mozilla "last build" :-(

Comment 5

15 years ago
Seeing this, but is stops some seconds after ! A server which is sending rotten
datas ?

Using a current cvs based trunk build, linux

Comment 6

15 years ago

Steps to Reproduce:
1.paste in location bar http://www.swift-tools.com/Flash/flash-0.4.10.tgz

Steps to *not reproduce*:
1.rigth button in link http://www.swift-tools.com/Flash/flash-0.4.10.tgz
2.click "save link target as"

Comment 7

15 years ago
Created attachment 125874 [details]
Negative Time on sourceforge.net download

I am using ...
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
on Windows XP Pro SP1

I have the same problem.

file downloaded:

it's not very reproducible, it happens on occasion. 1 out of every 50 or so
downloads.  when this has occured it's always been with the sourceforge.net
servers.  I can provide the badly downloaded tgz (it's way too large, and is
invalid anyway, but maybe you can gleen something useful from it.)

= real file =
  3492419 Feb 23 12:15 nethack-341.tgz
= badly downloaded file =
 15124480 Jun 17 21:55 nethack-341.tgz
*** Bug 239702 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
Could this be a duplicate of Bug 233047?
Product: Browser → Seamonkey

Comment 10

13 years ago
this worksforme with linux trunk 2005041305
Sobrinho: are you still seeing this bug with a recent build (1.7.x or 1.8b)?

Comment 11

13 years ago
If filesize > 2GB time and size go negative

Comment 12

13 years ago
If filesize > 2GB time and size go negative
If this is only with 2GB+ files, it's a duplicate of another bug.  The screenshots imply that this is in fact different.
Assignee: bross2 → download-manager
QA Contact: chrispetersen


11 years ago
Last Resolved: 15 years ago11 years ago
Resolution: --- → FIXED

Comment 14

11 years ago
What fixed this bug?  (Why was it resolved FIXED rather than WORKSFORME?)
You need to log in before you can comment on or make changes to this bug.