RTL lists are indented *outside* the page and horizontal scroll bar appears

RESOLVED FIXED

Status

()

Core
Layout: Text
--
major
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: Nir Soffer, Assigned: mkaply)

Tracking

({rtl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla 1.3 Final (I'm filling this bug using 1.2.1)

In 1.2.1, the first level of  RTL lists was indented inside the page (left) as
it should, but the next levels missed any more indentaion.

In 1.3 final, all the list levels are indented outside the page, so you can't
see the numbers or bullets. An horizontall scroll bar appears, one that you
can't get reed of by making the window larger.

Mozilla mail reader is affected also. You create a list and get no indentation
and the numbers are hidden outside the page.

Not usable for Hebrew site any more. Downgraded to 1.2.1 :-(

Reproducible: Always

Steps to Reproduce:
1. try any page with RTL lists




I tested this bug on both Winsows 2000 and Mac OS X. The bug is present in
Camino 0.7.

I did not find a way to report both OS in one bug report, so I add this info
here. Should I report this bug once for each os? 

If you enable multyply selection of OS in the OS list, this could solve the problem.
seeing the same with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a)
Gecko/20030322
If a bug is present in at least two major OSs, it's OK to mark ALL. Confirming
(on Windows and Linux), but it may be a dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 3

15 years ago
two bugs that might be related: bug #64510 and bug #74880
Depends on: 74880

Comment 4

15 years ago
still there on 1.4rc on winXP
Flags: blocking1.4?

Comment 5

15 years ago
mozilla1.4 shipped. unsetting blocking1.4 request.
Flags: blocking1.4?

Comment 6

14 years ago
IMHO, the problem seems to be that whenever there is a non-printed
character/separator between the <li> and the text that follows it, the
numbers/bullets will be displayed on the left side of the page.
I've used a simple style that apply to my examples:
<style>
li {padding-right: 20px;}
li p {display: inline; color: #333366;}
</style>
Maybe it can help in solving this issue temporarly and gives an idea on how to
permenantly fix it in the source.

Comment 7

14 years ago
Created attachment 137619 [details]
Page with modified <style>

Comment 8

14 years ago
You can find the original page here:
http://www.arabeyes.org/download/documents/guide/translator-guide-ar/x317.html
(Reporter)

Comment 9

14 years ago
Created attachment 138727 [details]
How to fix RTL lists with CSS 2 stylesheet

Show hot to fix RTL lists and make htem indentical to LTR lists. Works on both
Mozilla and Safari.

Safari does not break RTL list as Mozilla , but it indents too much.
Comment on attachment 138727 [details]
How to fix RTL lists with CSS 2 stylesheet

That's a good solution for page authors, but it doesn't work 100% of the time,
so we can't just put that style into html.css and solve the problem for all
cases.

An example where it doesn't work would be
<div dir="ltr">
  <ul dir="rtl">
  ...

Comment 11

14 years ago
Simon: Yes, you are right that this isn't a solution.
When I mentioned using CSS I was just trying to analyze the problem.
I mean, if Mozilla is modified in a way to add this extra spacing (smartly), it
would be a good fix (at least for now).
(Reporter)

Comment 12

14 years ago
Created attachment 138743 [details]
Workaround for authors that do work practically, using CSS 1

You just have to tag the first level list as either class="rtllist" or
class="ltrlist". Practically fix all cases, since lists are either RTL or LTR,
but never a mix.
Seams to be fixed since 1.7a
(Reporter)

Comment 14

14 years ago
Fixed in 1.7a
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

14 years ago
Does anyone know what fixed it?
See the bug this bug depends on.

Comment 17

14 years ago
this bug should have been RESOLVED DUPLICATE of bug 74880. some work was done
there recently, so it may be that some or all of the problems described here
were fixed there.

Comment 18

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.