Lost scroll position when window is resized horizontally

RESOLVED DUPLICATE of bug 19261

Status

()

Core
Document Navigation
--
minor
RESOLVED DUPLICATE of bug 19261
15 years ago
9 years ago

People

(Reporter: Ben Weaver, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i386; en-US; rv:1.4a) Gecko/20030323
Build Identifier: Mozilla/5.0 (X11; U; Linux i386; en-US; rv:1.4a) Gecko/20030323

In any page (the larger the page, the more noticable this is), when the browser
window is resized, the section of the content that is displayed is changed.  Of
course, if you were to resize the window vertically (to make it half as tall,
for instance) only half of what was formerly visible will be visible now, but
this is not what I mean.  When the window is resized horizontally, the place, or
position, that you are at in the content changes.  I noticied this while reading
a long story in my browser.  When I made my browser window narrower to see
something behind it, I suddenly found that my place in the story was completely
different. The best way to explain this is with an example.  Please follow the
steps to reproduce the problem below.

Reproducible: Always

Steps to Reproduce:
1. Make your browser window as wide as possible.
2. Go to http://outroad.org/mozillaWindowResizeBug.html
3. Scroll down until paragraph 500 is at the top of the browser window (about
half-way down) 
4. Resize your window horizontally so that it only takes up half of your desktop
(make it half as wide)
5. You will now find that you are somewhere else in the document, probably
around paragraph 350, depending on how large your desktop is and how much you
narrowed the window, I would guess.

Actual Results:  
The portion of the content that is displayed is not paragraph 500, but somewhere
around paragraph 350.

Expected Results:  
Whatever portion of the content that was at the top of the window before the
resize (in this case, paragraph 500) should be at the top of the window when the
user has finished resizing, they may continue reading where they left off
without scrolling to find their place again.

Comment 1

15 years ago
I see it too on XP,
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030323

What seems to be happening is that it is keeping the top line in the window the
same *number* of lines from the top of the page which, because of the line
wrapping, is not as far down the page. Not that I have any intention of counting
the lines in that page to prove it ;-)

The same thing happens if you change the text size from the View menu.

Updated

15 years ago
OS: other → All

Comment 2

15 years ago
Suggested behavior:

- At the beginning of re-sizing, note a point in the document corresponding
  to some point or line in the rendering area (e.g., the top of the pane,
  or wherever HTML anchors are placed for "...#anchor" URLs).
- While re-sizing, continually adjust the vertical scrolling position so that
  the noted point in the document is displayed at the top of the screen.

(That is, keep track of how far down the document is scrolled via the content,
not just the number of pixels scrolled.)

Updated

14 years ago
Assignee: asa → nobody
Status: UNCONFIRMED → NEW
Component: Browser-General → History: Session
Ever confirmed: true
QA Contact: asa → core.history.session
Summary: Portion of content changes when window is resized horizontally → Lost scroll position when window is resized horizontally

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 19261 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.