nsPluginTag::RegisterWithCategoryManager leaks pref service

VERIFIED FIXED in mozilla1.4alpha

Status

()

Core
Plug-ins
P3
normal
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

(Blocks: 1 bug, {mlk})

Trunk
mozilla1.4alpha
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch])

Attachments

(1 attachment)

1.91 KB, patch
Peter Lubczynski
: review+
Brian Ryner (not reading)
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

15 years ago
nsPluginTag::RegisterWithCategoryManager holds on to the pref service forever,
even though it has no need to do so.
(Assignee)

Comment 1

15 years ago
Created attachment 118254 [details] [diff] [review]
patch
(Assignee)

Updated

15 years ago
Attachment #118254 - Flags: superreview?(alecf)
Attachment #118254 - Flags: review?(peterlubczynski)
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Whiteboard: [patch]
Target Milestone: --- → mozilla1.4alpha
(Assignee)

Comment 2

15 years ago
*** Bug 198899 has been marked as a duplicate of this bug. ***
Comment on attachment 118254 [details] [diff] [review]
patch

sr=bryner
Attachment #118254 - Flags: superreview?(alecf) → superreview+

Comment 4

15 years ago
Comment on attachment 118254 [details] [diff] [review]
patch

r=peterl
Attachment #118254 - Flags: review?(peterlubczynski) → review+

Comment 5

15 years ago
Comment on attachment 118254 [details] [diff] [review]
patch

nice! This has been driving me nuts, and I couldn't figure out where it was
coming from!
sr=alecf
(Assignee)

Comment 6

15 years ago
Fix checked in to trunk, 2003-03-25 06:55 PST.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 7

15 years ago
Verified that the changes reflected in the attached patch were checked in on
03/25/03

CVS Log:
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp

Rev details:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=nsPluginHostImpl.cpp&root=/cvsroot&subdir=mozilla/modules/plugin/base/src&command=DIFF_FRAMESET&rev1=1.468&rev2=1.469
Status: RESOLVED → VERIFIED
Blocks: 60697
You need to log in before you can comment on or make changes to this bug.