PHP download script confuses mozilla

RESOLVED DUPLICATE of bug 183653

Status

RESOLVED DUPLICATE of bug 183653
16 years ago
14 years ago

People

(Reporter: bill, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

The above script downloads images.  Mozilla gets confused about how to deal with
the image.  Instead of simply displaying it, it asks which application to use to
open the image.  If I pick mozilla it will open the image just fine in a new
frame.  If I uncheck the box that says "ask every time," it still asks next time.

Using wget I have determined that the mime type reported is image/jpeg.  e.g. 

C:\>wget "http://forums.portent.net/attachment.php?s=&postid=1119284"
--22:24:54--  http://forums.portent.net/attachment.php?s=&postid=1119284
           => `attachment.php@s=&postid=1119284'
Resolving forums.portent.net... done.
Connecting to forums.portent.net[63.167.204.32]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 53,282 [image/jpeg]

100%[====================================>] 53,282       146.16K/s    ETA 00:00

22:24:55 (146.16 KB/s) - `attachment.php@s=&postid=1119284' saved [53282/53282]

Wget doesn't get the name right, but it does download it o.k.

Reproducible: Always

Steps to Reproduce:
1. Just paste enter the URL into the address bar and hit enter.

Actual Results:  
Got display box asking me what application to use to open the image.

Expected Results:  
Displayed the image.

*** This bug has been marked as a duplicate of 183653 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.