In quirks mode, Mozilla should use the user settings (for tables)

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: vincent-moz, Assigned: dbaron)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.4a) Gecko/20030315
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.4a) Gecko/20030315

Under some conditions, Mozilla sometimes ignores user settings in quirks mode,
and this can make pages difficult to read.

Reproducible: Always

Steps to Reproduce:
1. Set the default font size in userContent.css:
    html { font-size: 11pt !important }
2. Open the following HTML file:
<html><head><title>.</title><body>
<div>
<p>foo</p>
<table><tr><td>bar</td></tr></table>
</div>
</body></html>
Actual Results:  
"foo" will be displayed at 11pt as expected, but not "bar" (here, it is
displayed at a smaller font size, more difficult to read).

Expected Results:  
"bar" should be displayed at 11pt, like "foo".

Comment 1

16 years ago
Have you tried 'body { font-size: 11pt !important }' instead? I haven't found
much use in applying any rules to html in Mozilla.
(Reporter)

Comment 2

16 years ago
Same problem with 'body { font-size: 11pt !important }'.
Hardware: PC → All
(Assignee)

Comment 3

16 years ago
If you want to set font sizes, use the font size settings in preferences.  They
change things like what 'medium' is, etc.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

16 years ago
But using the font settings in preferences won't work if the page changes the
font size. The advantage of the user style sheet is that one can use the
"!important" keyword to override the page settings. I think that this bug should
be reopened.
(Assignee)

Comment 5

16 years ago
Wanting a better solution is a valid request (and there may be other bugs
requesting such a thing).  Wanting this particular solution is not (since it
doesn't make sense in terms of the way CSS works).
(Assignee)

Comment 6

16 years ago
(Better solutions might be things such as a persistent full zoom (bug 4821).)
(Reporter)

Comment 7

16 years ago
Oops, forget my comment.
  html { font-size: medium !important }
should do what I want.
See also http://devedge.netscape.com/viewsource/2002/table-inherit/ for an
author-side solution to the table-inheritance problem.
You need to log in before you can comment on or make changes to this bug.