GZip Transfer- and Content-Encoding support

VERIFIED DUPLICATE of bug 68517

Status

()

Core
Networking: HTTP
--
enhancement
VERIFIED DUPLICATE of bug 68517
15 years ago
15 years ago

People

(Reporter: Janick Bernet, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Opera/7.02 (Windows NT 5.0; U)  [en]
Build Identifier: 

I cannot say for sure if this is a real bug but for me the RFC isnt absolutely 
clear. Its that I want to make a server-proxy which compresses our server 
responses which works fine if you know the length of the whole compressed file. 
But now when Tomcats sends the content of a dynamic page the content is sent in 
chunkes. Now I'd like to forward the request again in compressed chunks. I know 
that after the RFC if I specifiy Content-Encoding the whole content should be 
encoded and not the individual chunkes, but then this works under Opera 7. So I 
tried to set Transfer-Encoding to chunked, gzip which should in my opinion 
achieve exactly that what I want, namely the chunkes beeing decoded, but this 
seems not to work under mozilla neither. 


Reproducible: Always

Steps to Reproduce:




see: http://www.w3.org/Protocols/rfc2616/rfc2616.html

Comment 1

15 years ago
related: bug 145216.

Updated

15 years ago
Whiteboard: DUPME?
(Reporter)

Comment 2

15 years ago
Somebody told me that I didn't make my point clear enough, so i'll try again:

Problem: Transfer chunked and gzipped, but the whole content-identity is not 
yet know, so only the individual chunks can be gzipped.

Solution 1 (not correct after RFC): 
 Response Header: 
   Content-Encoding: gzip
   Transfer-Encoding : chunked

Solution 2 (correct IMHO): 
 Response Header:
   Transfer-Encoding: chunked, gzip

In both cases the data is as I already mentioned gzipped chunk by chunk, so 
each chunk has its own gzip header and footer. Mozilla should support solution 
2, solution one would be nice to have (Opera 7 supports it), but is not 
necessary.
(Reporter)

Comment 3

15 years ago
Changed serverity to enhancement, because looking at the RFC again this is not a
bug.
Severity: normal → enhancement
(Assignee)

Comment 4

15 years ago
According to RFC 2616, content codings are applied to the entity before transfer
codings.  IOW, it is invalid to gzip a chunked message.  the message must be
gzip'd first, and then chunked.  Mozilla supports gzip'd chunks, using
Content-Encoding: gzip, but it does not support Transfer-Encoding: gzip (which
is already filed as bug 68517.

marking as duplicate.

*** This bug has been marked as a duplicate of 68517 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
Whiteboard: DUPME?
You need to log in before you can comment on or make changes to this bug.