image with relative paths not being loaded via innerhtml swap

RESOLVED FIXED in mozilla1.4beta

Status

()

Core
DOM: Core & HTML
P2
normal
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: Brian Youn, Assigned: bz)

Tracking

({regression, testcase})

Trunk
mozilla1.4beta
x86
All
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030324
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030324

In the page at "http://www.actsaustin.org/innerhtml_testcase.html", rolling the
mouse over the links labelled "number one" and "number two" should swap out the
image of the word "test" with an image of a numeral "1" (dark blue on white
background) and a numeral "2" (white text on black background, respectively). 
Clicking on the "click" link should swap the image out with an image of the word
"click" (yellow text on red background).  Rolling the mouse over the "reset to
test" link should reset to the image of the word "test".

In the current 1.4a 2003032404 build of Mozilla, none of the images are being
loaded correctly after the initial page load.

These swaps are done through use of innerhtml, and worked fine up until roughly
the 1.4a 2003031714 build, and stopped working at around the 20030320 builds,
and are still not working with the current nightlies.

Reproducible: Always

Steps to Reproduce:
1.Move mouse over "number one" or "number two" link
2.
3.

Actual Results:  
Image of the word "test" will disappear, instead of being replaced with the
correct image.

Expected Results:  
Rolling over "number one" should replace the image with an image of a dark blue
numeral "1" on white background.

Rolling over "number two" should replace the image with an image of a white
numeral "2" on a black background.

Clicking on "click" should replace the image with an image of yellow word
"click" on a red background.

Rolling the mouse over "reset to 'test'" should replace the image with an image
of the word "test", the same image that the page initially loads with.

Comment 1

15 years ago
a possible dup of bug 198435?

Comment 2

15 years ago
Created attachment 119158 [details]
variation on Brian's testcase

this testcase has an additional "ONE!" which has an absolute image path instead
of a relative path.  The absolute path works fine.

Comment 3

15 years ago
This bug occurs with linux 1.4a
it occurs with quirks mode and the image here shouldn't be "broken".
this seems to be a separate regression from 83774 (last worked with trunk
2003031805)

marking NEW
Blocks: 83774
Severity: minor → normal
Status: UNCONFIRMED → NEW
No longer depends on: 198435
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All

Updated

15 years ago
Summary: image not being loaded via innerhtml swap → image with relative paths not being loaded via innerhtml swap

Comment 4

15 years ago
*** Bug 200173 has been marked as a duplicate of this bug. ***
That testcase is not very usable (since it does not refer to actual existing
images)....

In any case, I suspect that fixing bug 198486 may fix this, since the nodes will
have the right document, hence the right base URI.  And indeed, the test URL
works in my build with that patch
Depends on: 198486

Comment 6

15 years ago
> (since it does not refer to actual existing images)

?  all the images from the testcase display fine with builds 2003031805 and earlier
Ah, I had missed the <base> tag.  My apologies....

Testcase works in my patched build too.
Assignee: dom_bugs → bzbarsky
Priority: -- → P2
Target Milestone: --- → mozilla1.4beta
*** Bug 200610 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
*** Bug 201637 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: regression
No longer blocks: 201861
*** Bug 201861 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
*** Bug 201954 has been marked as a duplicate of this bug. ***
Fixed by bug 198486 checkin.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
*** Bug 202436 has been marked as a duplicate of this bug. ***
*** Bug 203008 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
*** Bug 205215 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
*** Bug 206582 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: desale → general
You need to log in before you can comment on or make changes to this bug.