English Al Jazeera website articles don't load

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Arabic
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Heikki Toivonen (remove -bugzilla when emailing directly), Assigned: Katsuhiko Momoi)

Tracking

Details

(URL)

The page is basically empty, and relies on script to load stuff and redirect the
page. Unfortunately the script starts with:

var xml = new ActiveXObject("Microsoft.XMLDOM");

which will immediately throw an exception in Mozilla, and therefore we will not
show anything.

Comment 1

15 years ago
The front page works now.  It's the articles that don't work:

It displays the basic visual structure of the page (banner, mail/print links,
borders), the headline, but no article.

Works fine in IE 5.0

Moz 1.3 final on Win2K
Morphing bug to reflect the fact that articles don't load.
Summary: English Al Jazeera website shows up blank → English Al Jazeera website articles don't load

Comment 3

15 years ago
The problem is this:

<input id="articalText" type="hidden" value="<SPAN style=&quot;FONT-SIZE:14 pt;
FONT-FAMILY: Arial; mso-fareast-language: EN-US&quot;>

The entire article body is in the VALUE of a hidden INPUT. The INPUT VALUE is
never closed by a " until after the article body. All " in the article body,
even in the HTML elements, are escaped as &quote;
*** Bug 200761 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 200799 has been marked as a duplicate of this bug. ***
*** Bug 200855 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
To continue from comment 3:

The page then attempts to use document.all manipulation to copy the hidden input
value into the page body.

The whole page is riddled with MS-XML-isms.

Comment 8

15 years ago
*** Bug 201351 has been marked as a duplicate of this bug. ***
*** Bug 201540 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
This is confirmed in both Linuz 1.3 versions, WinXP 1.3 and 1.4a.
Both IE and KDE-Konqueror load these articles.
*** Bug 202043 has been marked as a duplicate of this bug. ***
*** Bug 202263 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
*** Bug 202275 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
Looks like it is fixed.

The code the manipulate the article body that is the value of a hidden input has
changed to:

if (navigator.appName.indexOf('Microsoft') != -1) 
{
	//thisbrowser="ie"
	if(document.all.artical)
		document.all.artical.innerHTML = document.all.articalText.value ;			
}
else
{
	//thisbrowser="NN6";
	if(document.getElementById("artical"))
		document.getElementById("artical").innerHTML =
document.getElementById("articalText").value ;	
}

But images in articles are broken in Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.4a) Gecko/20030410 Phoenix/0.5+

Choosing View Image from the context menu works though.

Comment 15

15 years ago
Images seems to work now - but I'm using an old build (Mozilla/5.0 (Macintosh;
U; PPC; en-US; rv:1.2.1) Gecko/20021130).

Comment 16

15 years ago
Confirm fixed on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030319
Debian/1.3-3.

Comment 17

15 years ago
The top left banner says "This temporary site is partially on hold until we
launch the full and permanent site of english.aljazeera.net at the end of
April... ..."

Might be better to leave the bug open until the permanent site is launched?
(Assignee)

Comment 18

15 years ago
I am going to move this to Arabic category. Though the site is in
English, we might be better off in Arabic category to get a volunteer or
two to work on this site in case intial suggestions don't work.  
Component: Middle Eastern → Arabic

Comment 19

15 years ago
The new site is up now. Everything seems to work.
Yup, wfm too
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.