"aqua" buttons with CSS background and color can cause invisible text

RESOLVED DUPLICATE of bug 198822

Status

Camino Graveyard
HTML Form Controls
RESOLVED DUPLICATE of bug 198822
15 years ago
15 years ago

People

(Reporter: Michael Blakeley, Assigned: Brian Ryner (not reading))

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030324 Chimera/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030324 Chimera/0.7+

http://blakeley.com/mozilla/test-ugly-button.html displays nice-looking aqua
buttons in Safari, and nice-looking styled buttons in Mozilla (nightly). With
Camino, the second button is rendered with extremely low-contrast (invisible)
text. This seems to be the result of a CSS background plus a CSS color: buttons
3 and 4 have just a background and just a color, respectively, and they render
fine. Button 1 has no style attribute.

Reproducible: Always

Steps to Reproduce:



Expected Results:  
I believe that the problem is Camino is honoring the color attribute in a CSS
block, but not within the style attribute. Given Camino's decision to use Aqua
buttons, I believe the correct fix is to ignore the color in CSS as well as in
the style attribute.

Conversely, Camino could honor it in both places, and honor the background
attribute as well. That would allow the HTML authors to make their own decisions
about text/background contrasts.

Comment 1

15 years ago
Confirming in the 2003-03-24-08 Camino NB.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
*** This bug has been marked as a duplicate of 198822 ***

*** This bug has been marked as a duplicate of 198822 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.