In Mail, sorting on the message size column is wrong

VERIFIED FIXED in M16

Status

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: mozilla, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Sorting on the "Message Size" column in mail is wrong, as it is sorting on the
text value instead of the binary number.  So, for example, a message of "17KB"
sorts before a message of "1KB".

To fix this, you should return a RDF integer literal when its requested for
sorting (with the magical "?sort=true" appending to the arc in question) on this
column.

Updated

19 years ago
QA Contact: lchiang → fenella
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M16
(Assignee)

Comment 1

19 years ago
I didn't even know I'd implemented this.
(Reporter)

Comment 2

19 years ago
*** Bug 20600 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

19 years ago
*** Bug 23415 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
*** Bug 23968 has been marked as a duplicate of this bug. ***

Comment 5

19 years ago
*** Bug 34975 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

19 years ago
this should be easy to fix and a few people have mentioned this in the feedback.
(Assignee)

Comment 7

19 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 8

19 years ago
Linux (2000-04-20-09-M16)
Win32 (2000-04-20-09-M16)
Mac (2000-04-20-10-M16)
This problem is fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.