Status

defect
RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: mrmazda, Assigned: rginda)

Tracking

({regression})

Bug Flags:
blocking1.4a -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
2003032416 Linux & 2003032412 OS/2 trunks tested (worked in previous builds:
20030322 Linux 2003032313 OS/2)

To reproduce:
1-open Chatzilla
2-join a channel
3-type first letters of a nick seen in chat window into command window
4-hit <tab>

Actual result:
1-nothing

Expected result:
1-nick is finished and a colon appended in command window
/me blames bryner - see also bug 198976
Keywords: regression

Comment 2

16 years ago
Confirmed on Windows 2000, build 2003032508, w/ ChatZilla 0.8.24.

Also, Ctrl+PageUp/PageDn, Ctrl+Tab, Ctrl+Shift+Tab also don't work.

Looks like something major, probably not-ChatZilla related. :)
*** Bug 199373 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Flags: blocking1.4a?

Comment 4

16 years ago
According to bryner, although it looks like bug 54035 broke tab-completion, the
patch to 'correct' it isn't going to help tab-completion (though, with luck, it
should fix the Ctrl-commands I found were also broken).

Comment 5

16 years ago
Posted patch fix (obsolete) — Splinter Review
not sure why it wasn't done this way in the first place...

Updated

16 years ago
Attachment #118888 - Flags: review?(rginda)
Could I point out that history isn't working quite as expected - you probably
need to cancel the event because the cursor motion effect (on windows at least
up/down maps to left/right on single-line textboxes) occurs after the history.

Updated

16 years ago
Flags: blocking1.4a? → blocking1.4a-

Updated

16 years ago
Attachment #118888 - Attachment is obsolete: true
Attachment #118888 - Flags: review?(rginda)

Comment 7

16 years ago
Posted patch fix v2Splinter Review
This patch also covers Neil's comment.

Updated

16 years ago
Attachment #119588 - Flags: review?(rginda)
(Assignee)

Comment 8

16 years ago
Comment on attachment 119588 [details] [diff] [review]
fix v2

r=rginda
Attachment #119588 - Flags: review?(rginda) → review+

Comment 9

16 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 10

16 years ago
reopening because it broke ctrl-tab
Status: RESOLVED → REOPENED
Hardware: PC → All
Resolution: FIXED → ---

Updated

16 years ago
Attachment #125686 - Flags: review?(rginda)
(Assignee)

Comment 12

16 years ago
Comment on attachment 125686 [details] [diff] [review]
patch(Ctrl+Tab, Ctrl+Shift+Tab)

included in next xpi
Attachment #125686 - Flags: review?(rginda) → review+

Comment 13

16 years ago
My patch was checked in. Thank you.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.