sound settings blocks stalked messages if WAV sound file is set

RESOLVED FIXED

Status

defect
--
major
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: bioram, Assigned: rginda)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

Set any WAV as a notification sound for private message tab or stalked message.
No private messages or stalked messages are shown.

Reproducible: Always

Steps to Reproduce:



Expected Results:  
WAV should be played and all messages should be shown.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
Also ChatZilla 0.8.23 [Mozilla rv:1.4a/20030318] WinXP

(although I get the private messages but in the main channel window) prefs are
set to display private messages in new window

Removing the custom sound and things work as expected.

Comment 2

16 years ago
*** Bug 199280 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
Might be caused by the implementation of bug 64462 (see
http://bugzilla.mozilla.org/show_bug.cgi?id=64462#c154) which fits in nicely
with the timeframe of somwhere between mozilla 1.1 and mozilla 1.2beta.

Also of interest is bug 199201, which might cover the same problem.

Comment 4

16 years ago
Posted patch patch v1Splinter Review
The cause is nsSound::Play() doesn't work. See bug 179138.

This patch handles the exception.

Updated

16 years ago
Attachment #119505 - Flags: review?(rginda)

Comment 5

16 years ago
I have just tested patch v1 and it works fine for me. I.e.: on /testdisplay I do
see all lines of output now, regardless of the stalk sound setting (beep or wave
sound file).

But I still don't hear the wav sound file being played. As just discussed with
Koike this bug here seems to be about the exception handling. Perhaps the
playing problem might be fixed with bug 179138.

Comment 6

16 years ago
This bug will be fixed with bug 207436.
Depends on: 207436

Comment 7

16 years ago
I don't think this is Linux specific... I have the (seemingly) same problem on
Windows 2000.
(Assignee)

Comment 8

16 years ago
Comment on attachment 119505 [details] [diff] [review]
patch v1

I moved the try/catch inside of playSound.
Attachment #119505 - Flags: review?(rginda) → review+
(Assignee)

Comment 9

16 years ago
marking fixed, 0.8.34 checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.