Modern contrib/ stuff lacks documentation

RESOLVED DUPLICATE of bug 356926

Status

()

Bugzilla
Documentation
P4
normal
RESOLVED DUPLICATE of bug 356926
16 years ago
11 years ago

People

(Reporter: Jacob Steenhagen, Unassigned)

Tracking

Details

(Reporter)

Description

16 years ago
There should be a section for documenting how to use the stuff in contrib. 
Among  other things, the script introduced in bug 198458 should be documented.
(Reporter)

Updated

16 years ago
Priority: -- → P4
Target Milestone: --- → Bugzilla 2.18
Yeah, I was going to do that as part of the checkin for that bug. :)

I have a full printout of the cvs logs for everything in that directory, and was
planning to expand the README file a bit :)
Adding Matt Barnson, who mentioned in IRC tonight that he was working on some of
this already.
Jake is leaving for a while (Reserve unit got called up), and we don't have a
new docs owner yet.  Anyone interested in helping out, please add
documentation@bugzilla.org to your watch list in your email preferences in Bugzilla.
Assignee: jake → documentation
Enhancements which don't currently have patches on them which are targetted at
2.18 are being retargetted to 2.20 because we're about to freeze for 2.18. 
Consideration will be taken for moving items back to 2.18 on a case-by-case
basis (but is unlikely for enhancements)
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
all docs are current milestone
Target Milestone: Bugzilla 2.20 → Bugzilla 2.18

Updated

12 years ago
QA Contact: mattyt-bugzilla → default-qa

Updated

12 years ago
Severity: enhancement → normal

Comment 6

12 years ago
For what it's worth, if you add POD to any of the files in contrib/, that POD will show up automatically in the API docs.
Summary: contrib/ stuff needs documentation → Modern contrib/ stuff lacks documentation

Updated

11 years ago
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20

Comment 7

11 years ago
I believe this is a duplicate of 356926, which has a patch under review
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 356926

Updated

11 years ago
Target Milestone: Bugzilla 2.20 → ---
You need to log in before you can comment on or make changes to this bug.