CompositeDataSourceImpl doesn't release observers in its destructor

RESOLVED FIXED in mozilla1.4alpha

Status

()

Core
RDF
P2
normal
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

({memory-leak})

Trunk
mozilla1.4alpha
memory-leak
Points:
---
Bug Flags:
blocking1.4a +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tind-mlk][patch])

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
CompositeDataSourceImpl doesn't release its observers in its destructor. 
Somehow we haven't noticed this leak until it showed up on tinderbox last night.

(The leak currently on tinderbox involves an nsXPCWrappedJS that's an observer,
and which, by staying alive, keeps a bunch of JS objects, including two global
objects, alive.)

The fix is trivial -- convert to nsCOMArray.
(Assignee)

Updated

15 years ago
Attachment #118553 - Flags: superreview?(alecf)
Attachment #118553 - Flags: review?(varga)
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
Whiteboard: [tind-mlk][patch]
Target Milestone: --- → mozilla1.4alpha
(Assignee)

Updated

15 years ago
Flags: blocking1.4a?

Comment 2

15 years ago
Comment on attachment 118553 [details] [diff] [review]
patch

nice!
sr=alecf
Attachment #118553 - Flags: superreview?(alecf) → superreview+

Comment 3

15 years ago
Comment on attachment 118553 [details] [diff] [review]
patch

looks good
r=varga
Attachment #118553 - Flags: review?(varga) → review+
(Assignee)

Updated

15 years ago
Attachment #118553 - Flags: approval1.4a?
(Assignee)

Comment 4

15 years ago
This should be pretty low-risk, although there's always the possibility that a
leak fix could expose overreleasing somewhere else and lead to crashes.  It's
also possible that this could fix leaks elsewhere.

Updated

15 years ago
Flags: blocking1.4a? → blocking1.4a+
Comment on attachment 118553 [details] [diff] [review]
patch

Should be safe, good to check out via an alpha release.

/be
Attachment #118553 - Flags: approval1.4a? → approval1.4a+
(Assignee)

Comment 6

15 years ago
*** Bug 199269 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

15 years ago
Fix checked in to trunk, 2003-03-26 16:01 PST.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.