All users were logged out of Bugzilla on October 13th, 2018

Keyboard shortcut for opening new tabs works differently than documented

RESOLVED FIXED in seamonkey2.0a1

Status

RESOLVED FIXED
16 years ago
12 years ago

People

(Reporter: martin, Assigned: bugzilla)

Tracking

(Blocks: 1 bug)

Trunk
seamonkey2.0a1
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

The documentation says that Insert opens a link in new foreground tab,
Shift+Insert in a new background tab. However, Navigator behaves exactly the
opposite way around.

Here is the diff I propose:
Index: mozilla-org/html/docs/end-user/moz_shortcuts.html
===================================================================
RCS file: /cvsroot/mozilla-org/html/docs/end-user/moz_shortcuts.html,v
retrieving revision 1.13
diff -u -r1.13 moz_shortcuts.html
--- mozilla-org/html/docs/end-user/moz_shortcuts.html	21 Mar 2003 18:08:05
-0000	1.13
+++ mozilla-org/html/docs/end-user/moz_shortcuts.html	26 Mar 2003 18:35:43 -0000
@@ -1068,7 +1068,7 @@
 <div align="left">Open link in new foreground tab</div>
 </td>
 <td bgcolor="#eeeeee">
-<div align="left">Insert</div>
+<div align="left">Shift+Insert</div>
 </td>
 <td bgcolor="#eeeeee">
 <div align="left">&nbsp;</div>
@@ -1082,7 +1082,7 @@
 <div align="left">Open link in new background tab</div>
 </td>
 <td> 
-<div align="left">Shift+Insert</div>
+<div align="left">Insert</div>
 </td>
 <td> 
 <div align="left">Shift+Insert</div>

There might be a connection to a developer issue:
http://bugzilla.mozilla.org/show_bug.cgi?id=185270

This is the first time that I file a bug to bugzilla - I appreciate your
feedback on how to make it better!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
doc:user is for Online Help content. mozilla.org:webmaster is for moz.org
content -> moz.org
Assignee: rudman → endico
Component: User → webmaster@mozilla.org
Product: Documentation → mozilla.org
QA Contact: rudman → imajes
Summary: keyboard shortcut for opening new tabs works differently than documented → Keyboard shortcut for opening new tabs works differently than documented
Version: unspecified → other

Comment 2

16 years ago
Actually, it's more complicated that that :)

In my brief testing it appears that "Insert" opens the highlighted link accoding
to the pref set in Navigator -> Tabbed Browsing (browser.tabs.loadInBackground)
and "Shift + Insert" does the opposit.

Comment 3

16 years ago
-> arron

actually, the page is an updated version of keyboard shortcut in Mozilla
Help, so partly belongs to documentation:user

arron, can you also update the shortcut table (accel+0) in Help and move
the online page from docs/end-user/ to catalog/end-user/?

btw, T is for "Mark this thread as read and go to next unread thread", not
"Go to Next Unread Thread"

and add a note that keyboard shortcut w/o modifier is case sensitive (e.g.
'T' should be 't')

also, Ctrl+# depends on what components you have (e.g. if you don't have
ChatZilla, Ctrl+3 opens Composer)

And the page should be expanded to explain mouse shortcuts (e.g.
ctrl+click on "compose/reply/reply all" button to swtich from default
html/text mode.)
Assignee: endico → aaronl
(Reporter)

Comment 4

16 years ago
The bug can be found in the End-User documentation that is delivered with the
Mozilla binary _and_ at the URL noted above. Sorry if that was not clear in the
original bug submission.

Comment 5

15 years ago
online doc removed. -> help content component
Assignee: aaronlev5 → rlk
Component: webmaster@mozilla.org → User
Product: mozilla.org → Documentation
QA Contact: imajes → stolenclover
Version: other → unspecified

Updated

15 years ago
Blocks: 232066

Updated

14 years ago
Assignee: rlk → nobody

Comment 6

14 years ago
Giacomo, does this still occurs? Since I'm on a mac I'm unable to test ;)

Comment 7

14 years ago
Comment #2 holds true. An update to the documentation is needed.
Good first bug? :)
(Assignee)

Updated

12 years ago
Assignee: nobody → aqualon
(Assignee)

Comment 8

12 years ago
I have 3 suggestions so far to solve this issue:

http://www.aquachan.de/moz/shortcuts-navigator.xhtml#tabbed_browsing_shortcuts
http://www.aquachan.de/moz/shortcuts-navigator_v2.xhtml#tabbed_browsing_shortcuts
http://www.aquachan.de/moz/shortcuts-navigator_v3.xhtml#tabbed_browsing_shortcuts

Any opinions on what's probably the best for a normal user or what could be improved?
Status: NEW → ASSIGNED

Comment 11

12 years ago
Comment on attachment 248292 [details] [diff] [review]
Patch v1

 </table>
+<p>
+  *...

You need an empty line between the table and the paragraph. Also, the indentation in the paragraph is wrong, should be like this:

<p>text .. ...
  more text....</p>

+  Switch to new tabs opened from links</a> setting is disabled. Other keys may also apply depending 
+  on the <a href="cs_nav_prefs_navigator.xhtml#tabbed_browsing"> Open tabs instead of windows</a> settings.

Looking at the last sentence, I think it will look/sound better if you wrote "Depending on the Open tabs instead of windows settings, more keys might be available."
Attachment #248292 - Flags: review?(stefanh)
(Assignee)

Comment 12

12 years ago
Created attachment 248669 [details] [diff] [review]
Patch v2: Addressing comments from Stefan
Attachment #248292 - Attachment is obsolete: true
Attachment #248669 - Flags: review?(stefanh)

Comment 13

12 years ago
Comment on attachment 248669 [details] [diff] [review]
Patch v2: Addressing comments from Stefan

+  of windows</a> settings, more keys might be available.
+</p>

Move the </p> up one line. r=me with that fixed.
Attachment #248669 - Flags: review?(stefanh) → review+
(Assignee)

Comment 14

12 years ago
Created attachment 248846 [details] [diff] [review]
Final version for checkin

Addressing issue from comment 13 and transfering r+ from Stefan
Attachment #248669 - Attachment is obsolete: true
Attachment #248846 - Flags: review+

Comment 15

12 years ago
Landed on trunk.

Updated

12 years ago
Component: Help Viewer → Help
Product: Documentation → Mozilla Application Suite
Target Milestone: --- → seamonkey1.5alpha
Version: unspecified → Trunk

Comment 16

12 years ago
(In reply to comment #15)
> Landed on trunk.
> 

Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.