Bookmarks broken in Phoenix since landing of bug 196756

VERIFIED FIXED in Firebird0.6

Status

()

defect
P2
major
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: seb, Assigned: p_ch)

Tracking

({regression})

unspecified
Firebird0.6
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Since the landing of bug 196756 in the trunk, the bookmarks are broken in Phoenix.
They seem to not be loaded at all (don't appear in the Bookmarks menu or in the
bookmarks toolbar, for example).
(Reporter)

Updated

16 years ago
Keywords: regression
(Reporter)

Comment 1

16 years ago
*** Bug 199347 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

16 years ago
*** Bug 199347 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
I fixed a few issues in Phoenix, they should load now at least.
It still needs some work, giving to Pierre for now.

Comment 4

16 years ago
Adding a bookmark into a specific folder gives me this exception (the bookmark
is still added though):

Error: uncaught exception: [Exception... "Component returned failure code:
0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIRDFService.GetResource]"  nsresult:
"0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame ::
chrome://browser/content/bookmarks/bookmarks.js :: anonymous :: line 1586" 
data: no]

Comment 5

16 years ago
Dragging the bookmark icon from the address bar to the personal toolbar yields
this exception:

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIBookmarksService.isBookmarked]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://browser/content/bookmarks/bookmarks.js :: anonymous :: line 1410" 
data: no]

Comment 6

16 years ago
the sidebar is pretty busted double clicking links doesn't work, although right
clicking and choosing open does. also the spacers have bookmark icons on them
and can be clicked, which produces an error

Comment 7

16 years ago
Jan: do we need to port patches to mozilla to phoenix? esp. interface codes.

Comment 8

16 years ago
-> P2

chanial:
Is this bug should target to Phoenix0.6?
Priority: -- → P2
(Assignee)

Comment 9

16 years ago
Noririty: sure. tareting for 0.6
back to Jan. I have no time, atm.
Assignee: chanial → varga
Target Milestone: --- → Phoenix0.6
(Reporter)

Comment 11

16 years ago
*** Bug 200260 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
It also appears that the "Add Bookmark" dialog box doesn't go away when you
click "OK".  You have to hit cancel.
(Reporter)

Updated

16 years ago
Depends on: 200401

Comment 13

16 years ago
An additional problem has occurred with the 20030402 build. If I make any
changes to the bookmark file, such as moving bookmarks, from within the bookmark
mananger, the changes last until I exit Phoenix. When I restart Phoenix all
changes are lost.
(Reporter)

Comment 14

16 years ago
Corwin, your problem is bug 200401
Has this anything to do with bug 200480?

Comment 16

16 years ago
Ok, some bookmarks related Javascript Error Messages:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520008 (NS_ERROR_FILE_ALREADY_EXISTS) [nsIRDFRemoteDataSource.Flush]"
nsresult: "0x80520008 (NS_ERROR_FILE_ALREADY_EXISTS)" location: "JS frame ::
chrome://browser/content/bookmarks/addBookmark2.js :: onOK :: line 97" data: no]

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520008 (NS_ERROR_FILE_ALREADY_EXISTS) [nsIRDFRemoteDataSource.Flush]"
nsresult: "0x80520008 (NS_ERROR_FILE_ALREADY_EXISTS)" location: "JS frame ::
chrome://browser/content/bookmarks/bookmarks.js :: anonymous :: line 1474" data: no]

Error: uncaught exception: [Exception... "Component returned failure code:
0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIRDFService.GetResource]" nsresult:
"0x80070057 (NS_ERROR_ILLEGAL_VALUE)" location: "JS frame ::
chrome://browser/content/bookmarks/bookmarks.js :: anonymous :: line 1586" data: no]

I actually went and checked those lines.. it seems like the
nsIRDFRemoteDataSource.Flush() is broken, since it returns an error code and
writes the bookmarks to %temp% directory instead of overwriting the file. 
(Reporter)

Updated

16 years ago
No longer depends on: 200401

Comment 17

16 years ago
*** Bug 200737 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
*** Bug 200836 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 19

16 years ago
(for future triaging) The drag'n'drop problem with the bookmarks toolbar is bug
199364.
(Reporter)

Comment 20

16 years ago
Forget comment #19, bug 199364 was Mozilla-only.

Jan, would it be possible to port the fix from bug 199634 to Phoenix?

Comment 21

16 years ago
With the last few nightly builds (including most recent as of this moment,
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030408
Phoenix/0.5+), I can't import bookmarks at all -- nothing happens, no error, etc.
(Reporter)

Comment 22

16 years ago
*** Bug 201503 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 23

16 years ago
*** Bug 201503 has been marked as a duplicate of this bug. ***

Comment 24

16 years ago
Bookmarks seem to work fine for me since the 2003-04-09 build.
(Reporter)

Comment 25

16 years ago
Nah, drag'n'drop is still broken, and there are still icons on separators in the
bookmarks manager, among others.

Comment 26

16 years ago
i have 11.04.2003 nightly and you can't import your bookmarks - nothing happens.
nothing happens too when you drag urls to the personal toolbal field.
(Reporter)

Comment 27

16 years ago
*** Bug 201791 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
*** Bug 202372 has been marked as a duplicate of this bug. ***

Comment 29

16 years ago
I built 2003-04-02 with perfectly find bookmarks, but 2003-04-17 is definitely still broken.  Shouldn't this be more severe than "major?"

Comment 30

16 years ago
It was broken in the 2003-04-15 build, too.

Bookmarks still won't import from anything, you still can't drag anyyhing 
onto the Bookmarks Toolbar, nor are they sorted on the Bookmarks 
Toolbar as they are in the Bookmarks Manager.  (That sorting problem is 
also occuring in Mozilla 1.3.)
*** Bug 202663 has been marked as a duplicate of this bug. ***

Comment 32

16 years ago
a massive patch (i suppose).

this patch is _NOT_ final, it generates many warnings in JavaScript Console,
removed open in tabs function etc. etc.

this patch does not fix: 
1. exceptions in RDF...
2. personal toolbar DnD issues...

this patch fixes: 
1. new add bookmark dialog
2. new bookmarks management dialog
3. new properties dialog

Comment 34

16 years ago
bug 202477. Closing any browser window causes loooong hang (@
nsBookmarksService::WriteBookmarks).

bug 199872. Bookmarks service doesn't appear to import IE favorites
(does Phoenix has OSX build? :D)

Comment 35

16 years ago
Reassigning to nobody for now, feel free to take it.
Assignee: varga → nobody
(Assignee)

Comment 36

16 years ago
back to me.
Chu: I am sorry if you have invested time, I wasn't cc'd to this bug so I was
not aware of your work.

Assignee: nobody → chanial
(Assignee)

Comment 37

16 years ago
marking fixed.
I think most of the issues due to the bookmark landing in seamonkey are now
fixed. But a detailed QA is needed here. I still have to sync the
nsBookmarksService.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 38

16 years ago
chanial: 
have you looked into my nsBookmarksService.cpp patch? I think it contains some
new changes from Mozilla.

and... Why addBookmark2.* is needed in *cough* Firebird? I think the new Mozilla
add bookmark window is quite nice and actually better than the one in Firebird.

At last... it seems that bookmark saving is still broken. (This may be my
problem through)

tried: 
rm -rf .phoenix/
[start phoenix]
phoenix created a default set of bookmarks
restart phoenix
oops... all are gone except web panels...

P.S. what is web panels in fact?
(Assignee)

Comment 39

16 years ago
> have you looked into my nsBookmarksService.cpp patch? I think it contains some
new changes from Mozilla.
Yes, I will have a look to it.

> and... Why addBookmark2.* is needed in *cough* Firebird? I think the new
Mozilla add bookmark window is quite nice and actually better than the one in
Firebird.
Because I still do prefer the phoenix dialog even if it must be *a lot* improved
And because addBookmark.js is just horrible.
fwiw, addBookmark.* will be removed.

> At last... it seems that bookmark saving is still broken. (This may be my
problem through)
it works fine here (tm) have you pulled and built phoenix with my checkin already?
if you still encounter the pb, please file a bug

> P.S. what is web panels in fact?
I guess it will be used to display mini web pages in the sidebar (like mozilla)
(Assignee)

Comment 40

16 years ago
ok. I also sync'd the bookmarks service

Comment 41

16 years ago
Did this make it into the nightly? Or will that be in the next one? Just
downloaded the latest (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a)
Gecko/20030421 Phoenix/0.5+) and importing bookmarks still has no effect.
(Assignee)

Comment 42

16 years ago
Yes, it made the nighly, but there are still glitches (mostly shared by mozilla now)
I opened bug 202879 for the Import failure.

Please open new bugs for the remaining issues since there are a lot of people
cc'd to that bug.

Updated

16 years ago
Depends on: 202915

Comment 43

16 years ago
*** Bug 203128 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 44

16 years ago
v
Status: RESOLVED → VERIFIED

Comment 45

16 years ago
I still cannot drag a link from a webpage to anywhere (personal toolbar, tab,
etc.)(FB 2003-12-01, winNT), yet this bug was marked fixed back in April.
Reopen? (sorry if this is bugspam)
Check if you have the bookmarks.html in your profile or create a new profile.
That sounds like profile-trouble. Your issue is with 99.9% probability not the
same as this bug. 
Please refer to http://forums.mozillazine.org/viewforum.php?f=38 before going on
bug-hunt in bugzilla. :-)
You need to log in before you can comment on or make changes to this bug.