Sidebar contents missing (empty, no tabs displayed)

VERIFIED DUPLICATE of bug 195213

Status

SeaMonkey
Sidebar
--
minor
VERIFIED DUPLICATE of bug 195213
15 years ago
13 years ago

People

(Reporter: Stewart, Assigned: shliang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030322
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030322

Immediately after starting Mozilla, the sidebar (initially collapsed, but upon
opening) is empty.  The top line (the title "Sidebar", the "Tabs" drop-down
menu, and the "X" close button are present), but nothing but the grey background
is displayed below them.  (It appears as if all Sidebar Tabs are switched off,
but they are not; there are checkmarks beside each tab under the "Tabs"
drop-down menu).

This was (as of 1.2) an intermittent problem; sometimes, when creating a window,
Mozilla would determine (somehow) that the Sidebar would not function in this way.

Now, it acts this way every time Mozilla is started.  Opening another Mozilla
window usually results in a working sidebar... in that new window.  Closing (as
opposed to collapsing) the Sidebar, and then activating it again via the View
menu will cause the Sidebar to work correctly in that window.  Simply collapsing
the Sidebar and then expanding it again has no effect on this problem.

In 1.3, after opening another window (with a working Sidebar!), then switching
off all tabs in that working Sidebar, then switching them all back on again, and
then finally closing that window and returning to the window with the
non-functional, currently collapsed sidebar, I expanded the Sidebar to make
another test... and it worked!  Playing around with it awhile longer, it appears
that adding a tab to the Sidebar (turning any tab on; turning the tab off
immediately preceding turing it on works too) makes all the Sidebars in the
Mozilla application work properly -- i.e. reappear.  The Sidebar can be
collapsed or expanded without making any difference.


Reproducible: Always

Steps to Reproduce:
1. Start Mozilla with the Sidebar's initial state being "collapsed".  (It
appears to work properly from the "expanded" [normal default on first starting]
and "closed" states.)
2. Expand the Sidebar (by clicking on that bar on the left of your window).
3. Stare in bafflement.  Please!  ("Where's my Sidebars!?")

Actual Results:  
The Sidebar is empty (as described above).

Expected Results:  
I'd like my Sidebars to appear in the Sidebar.  My History, Bookmarks, etc. (and
yes, they ARE set ON under the "Tabs" listing).


GCC 3.2.1
libc 2.3.1
Linux 2.4.20
(any theme; doesn't matter)

Comment 1

15 years ago
looks like bug 195213

*** This bug has been marked as a duplicate of 195213 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
verified
Status: RESOLVED → VERIFIED
QA Contact: sujay → gbush
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.