Closed Bug 19942 Opened 22 years ago Closed 22 years ago

Cookie Manager displays incorrect information while shift-clicking

Categories

(Core :: Networking: Cookies, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: kennedyh, Assigned: morse)

References

Details

Open the cookie manager (Edit->Wallet->Display Cookies...)

Click on a cookie. The "Information about the selected Cookie" pane displays the
cookie contents.
Hold down the Shift key and click on another cookie, the original cookie remains
highlighted (and selected, because if you hit remove, the highlighted cookie is
removed), but the cookie information changes to that of the cookie you
shift-clicked on.

While this is more disconcerting than dangerous, its still broken.
Status: NEW → ASSIGNED
Target Milestone: M12
OS: Windows NT → All
Hardware: PC → All
This bug is also present in my Solaris 2.6 build of M11.
Hmm, very interesting.  I didn't believe it when I read it but I just tried it
and indeed it does what is described.

Pressing Shift should have no effect.  The only control key that should have
effect is control and that is used to select multiple cookies.  So the behavior
that the original cookie remains hilighted (and only that cookie) is correct, as
is the fact that that is the only cookie that gets deleted.  The fact that the
properties of the other cookie are displayed is incorrect.

Ben Goodger, do you have any ideas here.  If not, I'll  be back from vacation
next Tuesday and will look into this.
The Shift key is used to select multiple elements in Windows, just try
explorer, click an item, then shift click another item and every item between
the first item and the second item is selected. ["range selection"] With Ctrl,
only the elements clicked gets selected - ["discontiguous selection"] (I am told
 that on Macintosh the reverse is true)

Playing with the tree widget I note the Shift behaviour isn't working properly,
I shall file a bug.

I looked at Windows Explorer to see how it did multiple selections, and it just
says "x objects selected, yyy KB" .. we don't really need anything like that
here so I'll just adapt the code slightly so that no data is displayed (the
fields cleared) when there is more than one cookie selected.
Ben Goodger has a fix for this and will be checking it in.  He'll mark this
report as "fixed" when he does the check-in.
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
fix for multiple selected elements checked in. When multiple cookies are
selected, the data area now clears all the fields.

As for the shift-clciking, I think that might be a tree issue, selections are
not yet behaving exactly as one might expect. If things still do not work the
way you expect them, please let me know and I'll bother the <tree>-huggers.
Status: RESOLVED → VERIFIED
verified working on NT and Linux (both 2000010308)
*** Bug 32326 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.