Closed Bug 199421 Opened 22 years ago Closed 22 years ago

Embedded browsers crash when submitting login form [@ GtkPromptService::ConfirmEx ]

Categories

(Core Graveyard :: Embedding: GTK Widget, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lwillis, Assigned: blizzard)

References

()

Details

(Keywords: crash, Whiteboard: fixed1.4a)

Crash Data

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030320

Visit the above URL and attempt to login (The guest, and guest details will 
do ...) in either epiphany, or TestGtkEmbed and you get a crash and core-dump. 
Backtrace is as below:

#0  0x4002a247 in GtkPromptService::ConfirmEx(nsIDOMWindow*, unsigned short 
const*, unsigned short const*, unsigned, unsigned short const*,
unsigned short const*, unsigned short const*, unsigned short const*, int*, 
int*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/libgtkembedmoz.so
#1  0x409c3771 in nsPrompt::ConfirmEx(unsigned short const*, unsigned short 
const*, unsigned, unsigned short const*, unsigned short const*,
unsigned short const*, unsigned short const*, int*, int*) () 
from /home/lwillis/garnome/lib/mozilla-1.4a/components/libembedcomponents.so
#2  0x42272fc8 in Wallet_3ButtonConfirm () 
from /home/lwillis/garnome/lib/mozilla-1.4a/components/libwallet.so
#3  0x4227f820 in si_3ButtonConfirm(unsigned short*, nsIDOMWindowInternal*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libwallet.so
#4  0x42283a81 in si_OkToSave(char const*, char const*, nsString const&, 
nsIDOMWindowInternal*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libwallet.so
#5  0x42283e5d in si_RememberSignonData(nsIPrompt*, char const*, char const*, 
nsVoidArray*, nsIDOMWindowInternal*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libwallet.so
#6  0x42284062 in SINGSIGN_RememberSignonData () 
from /home/lwillis/garnome/lib/mozilla-1.4a/components/libwallet.so
#7  0x4227db83 in WLLT_OnSubmit () from /home/lwillis/garnome/lib/mozilla-
1.4a/components/libwallet.so
#8  0x42270429 in nsWalletlibService::Notify(nsIContent*, 
nsIDOMWindowInternal*, nsIURI*, int*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libwallet.so
#9  0x40dec53f in nsHTMLFormElement::NotifySubmitObservers(nsIURI*, int*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#10 0x40dec039 in nsHTMLFormElement::SubmitSubmission(nsIPresContext*, 
nsIFormSubmission*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#11 0x40debeb4 in nsHTMLFormElement::DoSubmit(nsIPresContext*, nsEvent*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#12 0x40debd8a in nsHTMLFormElement::DoSubmitOrReset(nsIPresContext*, 
nsEvent*, int) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#13 0x40debc23 in nsHTMLFormElement::HandleDOMEvent(nsIPresContext*, nsEvent*, 
nsIDOMEvent**, unsigned, nsEventStatus*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#14 0x40c1b101 in PresShell::HandleDOMEventWithTarget(nsIContent*, nsEvent*, 
nsEventStatus*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#15 0x40e04f94 in nsHTMLInputElement::HandleDOMEvent(nsIPresContext*, 
nsEvent*, nsIDOMEvent**, unsigned, nsEventStatus*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#16 0x40c1ae9b in PresShell::HandleEventInternal(nsEvent*, nsIView*, unsigned, 
nsEventStatus*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#17 0x40c1adb8 in PresShell::HandleEventWithTarget(nsEvent*, nsIFrame*, 
nsIContent*, unsigned, nsEventStatus*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#18 0x40dad518 in nsEventStateManager::CheckForAndDispatchClick
(nsIPresContext*, nsMouseEvent*, nsEventStatus*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#19 0x40dabb69 in nsEventStateManager::PostHandleEvent(nsIPresContext*, 
nsEvent*, nsIFrame*, nsEventStatus*, nsIView*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#20 0x40c1af45 in PresShell::HandleEventInternal(nsEvent*, nsIView*, unsigned, 
nsEventStatus*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#21 0x40c1a6d5 in PresShell::HandleEvent(nsIView*, nsGUIEvent*, 
nsEventStatus*, int, int&) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#22 0x40f583cf in nsViewManager::HandleEvent(nsView*, nsGUIEvent*, int) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#23 0x40f4b5e6 in nsView::HandleEvent(nsViewManager*, nsGUIEvent*, int) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#24 0x40f577c9 in nsViewManager::DispatchEvent(nsGUIEvent*, nsEventStatus*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#25 0x40f4ad2d in HandleEvent(nsGUIEvent*) () 
from /home/lwillis/garnome/lib/mozilla-1.4a/components/libgklayout.so
#26 0x410b5b7e in nsCommonWidget::DispatchEvent(nsGUIEvent*, nsEventStatus&) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libwidget_gtk2.so
#27 0x410adb8b in nsWindow::OnButtonReleaseEvent(_GtkWidget*, 
_GdkEventButton*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libwidget_gtk2.so
#28 0x410b14d3 in button_release_event_cb(_GtkWidget*, _GdkEventButton*) ()
   from /home/lwillis/garnome/lib/mozilla-1.4a/components/libwidget_gtk2.so
#29 0x40386473 in _gtk_marshal_BOOLEAN__BOXED (closure=0x81e6630, 
return_value=0xbffff030, n_param_values=2, param_values=0xbffff150,
    invocation_hint=0xbffff058, marshal_data=0x0) at gtkmarshalers.c:82
#30 0x40620d92 in g_closure_invoke (closure=0x81e6d20, 
return_value=0xbffff030, n_param_values=2, param_values=0xbffff150,
    invocation_hint=0xbffff058) at gclosure.c:437
#31 0x40632625 in signal_emit_unlocked_R (node=0x8081550, detail=0, 
instance=0x81e6630, emission_return=0xbffff0f0,
    instance_and_params=0xbffff150) at gsignal.c:2822
#32 0x40631492 in g_signal_emit_valist (instance=0x81e6630, signal_id=0, 
detail=0,
    var_args=0xbffff2e0 "רע�¿\bד\a\b\210d\036\b\210d\036\bרע�¿") at 
gsignal.c:2564
#33 0x406318b6 in g_signal_emit (instance=0x81e6630, signal_id=28, detail=0) 
at gsignal.c:2612
#34 0x404614bd in gtk_widget_event_internal (widget=0x81e6630, 
event=0x82271c8) at gtkwidget.c:3143
#35 0x40386249 in gtk_propagate_event (widget=0x81e6630, event=0x82271c8) at 
gtkmain.c:2267
#36 0x40384f7c in gtk_main_do_event (event=0x82271c8) at gtkmain.c:1502
#37 0x4053be70 in gdk_event_dispatch (source=0x1c, callback=0, user_data=0x0) 
at gdkevents-x11.c:2018
#38 0x4066f41e in g_main_dispatch (context=0x8073c50) at gmain.c:1653
#39 0x406703f9 in g_main_context_dispatch (context=0x8073c50) at gmain.c:2197
#40 0x40670713 in g_main_context_iterate (context=0x8073c50, block=1, 
dispatch=1, self=0x80759b8) at gmain.c:2278
#41 0x40670da4 in g_main_loop_run (loop=0x8228380) at gmain.c:2498
#42 0x403847a7 in gtk_main () at gtkmain.c:1092
#43 0x08049ea3 in main ()
#44 0x4079a082 in __libc_start_main () from /lib/i686/libc.so.6


Reproducible: Always

Steps to Reproduce:
1. Open TestGtkEmbed
2. Visit http://portal.plus.net/central.html?action=new_forums
3. Enter "guest" and "guest" on the log-in form and hit submit

Actual Results:  
Core dumped.

Expected Results:  
Submitted the form and carried on browsing
CC-ing Marco as this was originally reported as an epiphany bug and he may 
have input:

see:
http://bugzilla.gnome.org/show_bug.cgi?id=109144
Keywords: crash
Summary: Embedded browsers crash when submitting login form → Embedded browsers crash when submitting login form [@ GtkPromptService::ConfirmEx ]
Attached patch patchSplinter Review
This is a simple null check fix.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #118659 - Flags: review?(bryner)
Flags: blocking1.4a?
Attachment #118659 - Flags: review?(bryner) → review+
*** Bug 199568 has been marked as a duplicate of this bug. ***
Supplied patch works for me - thanks for the speedy response!
Attachment #118659 - Flags: approval1.4a?
Attachment #118659 - Flags: approval1.4a? → approval1.4a+
Checked in.
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Whiteboard: fixed1.4a
Flags: blocking1.4a?
Crash Signature: [@ GtkPromptService::ConfirmEx ]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: