Closed Bug 19944 Opened 20 years ago Closed 20 years ago

[BACKGROUND] GIF transparency 7 tables broken on complex GIF

Categories

(Core :: ImageLib, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: richard, Assigned: dcone)

References

()

Details

Attachments

(1 file)

The home page at this site (viewable fine in IE5) shows a problem with the
rendering of complex transparent GIFs as table backgrounds. Instead of showing
the background through the checkered transparent/colored grid, transparency
turns to black. Suprisingly, moving the mouse over a link on the page fixes the
region in which that link resides, but nowhere else. Build 1999111520 on Windows
NT 4.0SP5 with ATI 3D Rage IIC AGP driver 5.2.040 in 1152x864x32bpp. The may
need to go to ImageLib. This site worked in Milestone 8 to my rememberance.
The test case works fine in Nav 4.5 but has problems in Mozilla and IE 5.  Its
supposed to gray out the background by drawing a black pixel on every other
pixel... creating a shadow effect (Sort of like opacity: 0.5;)

In moz I get a black and blue mess where the transparency is supposed to be.
**The attachment is a ZIP.
Component: HTMLTables → ImageLib
Confirmed exactly as reported with 1999-12-08-08-M12 nightly binary on
Windows NT 4.0sp3.

This is almost certainly related to bug 1248 "Bottommost portion of images
filled w/garbage during rendering" in some way - it is entirely possible
that a satisfactory fix for bug 1248 will also fix this bug.

Not sure what the proper component for this bug is - trying "ImageLib"
instead of "HTML Tables" - with CSS, tables aren't the only way to get one
image on top of another.
Assignee: karnaze → pnunn
Reassingin to Pam based on previous comments.
Status: NEW → ASSIGNED
Target Milestone: M13
I have a feeling this is a table rendering issue not a gif
rendering issue. I'll take the bug and dig into the problem
and reassign if necessary.
Yes, this does look like a table-related issue, with possible XHTML+CSS
complications. Made a simple testcase with grid.gif as an <IMG> over the
bg-house.gif background referenced as an attribute on <BODY>, (plain old
HTML 3.2) and this worked correctly.

Also, grid.gif renders over the background as intended while it is loading,
and only looks wrong (transparent pixels black) once it is finished.
Confirmed mouseover detail.

Tested with: 1999-12-09-08-M12 nightly binary on Windows NT 4.0sp3.
QA Contact: chrisd → elig
Assignee: pnunn → dcone
Status: ASSIGNED → NEW
I can't reach www.hawkinsvinyl.com, so I am using
the attached zip file.

This is pretty interesting. If you shorten the text in
the table cell, thereby making the table cell smaller,
it will work.
Try it.
<body background="mozilla-banner.gif" text="#ffffff">
  <table background="shadow.gif" border=4 width=100>
   <tr>
    <td> The image under this  </td>
   </tr>
  </table>
 </body>
will work.

I'm betting this has to do with background tiling.
I'm reassing to dcone. Let me know if I can help.
I have other tests that show whats happening but the
above html is the simplest.
-pn
Status: NEW → ASSIGNED
Target Milestone: M13 → M14
Summary: GIF transparency broken on complex GIF → [BACKGROUND] GIF transparency 7 tables broken on complex GIF
Background images with transparency can not use general speedup for backgrounds.
Fixed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Since this is a table-specific issue, rather than a problem within ImageLib,
assigning to chrisd for BSC verification.
QA Contact: elig → chrisd
Keywords: verifyme
verified fixed with 070608 mozilla build on NT
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.