DOMParser replaces unicode - representation is replaced by caracter- representation

RESOLVED DUPLICATE of bug 199439

Status

()

Core
HTML: Parser
--
enhancement
RESOLVED DUPLICATE of bug 199439
15 years ago
15 years ago

People

(Reporter: Palm Kevin, Assigned: harishd)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

When you parse an xml-document, then the DOMParser replaces all unicodes by its
caracter-representation.

An example can be found here :
http://users.skynet.be/palm.kevin/mozilla/specialCarac.xul (Needs to be
downloaded; The online version doesn't work (why ?!?))

Reproducible: Always

Steps to Reproduce:

Actual Results:  
the unicode is replaced by the caracter

Expected Results:  
the unicode shouldn't change

*** This bug has been marked as a duplicate of 199439 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.