Browser locks up displaying table with extended characters at base of page

RESOLVED DUPLICATE of bug 136362

Status

Core Graveyard
GFX: Gtk
--
critical
RESOLVED DUPLICATE of bug 136362
16 years ago
10 years ago

People

(Reporter: Martin Hardcastle, Assigned: blizzard)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

At http://www.debian.org/, Mozilla (under Linux) locks up when you scroll down
to the list of alternative languages at the bottom of the page. True in 1.0,
1.2.1 and 1.3. Windows Mozilla copes. A local copy of the page gives the same
errors.

Reproducible: Always

Steps to Reproduce:
1. Go to www.debian.org
2. Scroll down to bottom of page


Actual Results:  
Browser locks up and must be killed from command line

Expected Results:  
Displayed the page

Tested on several machines and versions of Mozilla.
Is it Mozilla that's locked up, or the X font server?
Assignee: font → blizzard
Component: Layout: Fonts and Text → GFX: Gtk

Comment 2

16 years ago
worksforme with linux trunk 20030326 and 1.3
Keywords: hang

Comment 3

16 years ago
WFM on both 2003032608 and hours old CVS build with GTK2/xft
(Reporter)

Comment 4

16 years ago
Thanks for the WFMs which motivated me to go and test on a wider range of
systems. This appears to be a problem with an interaction between Mozilla and
XFree86 4.1, still the default for Debian stable systems. It's resolved on my
test Debian/stable machines by upgrading to XFree86 4.2.1. I don't know whether
non-Debian machines with 4.1 would show the same behavior, since I couldn't find
any! Still a bug that the browser locks, IMO...

Comment 5

15 years ago
So, do we know whether this is a but in Moz or in XFree86 4.1?

If a bug in XFree86 4.1, I suggest resolve INVALID...

Comment 6

15 years ago
Martin: are you running Xinerama (bug 136362)?
(Reporter)

Comment 7

15 years ago
Yes, I'm running Xinerama on the one machine that now exhibits the problem --
seems very likely to be the same as bug 136362.

Comment 8

15 years ago
ok.
marking dupe of "using Xinerama and Xfs can hang the browser"
if you can reproduce this without Xinerama, reopen (but I think that's unlikely)

also, people in bug 136362 have reported the bug continuing with XFree86 4.2.x

*** This bug has been marked as a duplicate of 136362 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.