Composer will refuse to edit a file with an OBJECT DATA tag

RESOLVED FIXED

Status

()

Core
Editor
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Giorgio Agrelli, Assigned: Joe Francis)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Trying to edit a file with an OBJECT DATA tag will fail with Mozilla 1.3
Composer is working ok if you insert a <OBJECT data="filetoembed.html"></object>
but if you close the file and try to edit it again composer will not let you
modify the entiere paga, but it will display it correctly

Reproducible: Always

Steps to Reproduce:
1.open composer
2.create a table
3.go to "insert -> html" menu
4.fill in sth like <Object data="filetoembed.html"> can't open file </object>
5.save the file
6.close composer
7.open composer and try to edit the file you just saved, it's impossible to
modify it now, clicking on the tabs below the edit window (HTML tags, Normal,
Source, Preview) has no effect too... but the file is displayed correctly

with previous versions of mozilla the behaviour was correct (i tried the 1.0 and
for what i remember 1.2.1 was doing it fine)
Actual Results:  
It's impossible to edit the file
the problem is not related to file permissions
the problem is not happening with previous versions of mozilla

Expected Results:  
Mozilla should allow to modify the page like usual
the problem is no happening with mozilla 1.0 and i guess 1.2.1 was behaving
correctly too...

I guess it's not system related any way i'm using linux Slackware 8.1 and the
tarballs of mozilla 1.3... regular modern teme and no localization even if
italian language pack is installed i'm not using it...
(Reporter)

Comment 1

15 years ago
The bug is Fixed with mozilla 1.4a and 1.4b... works great!!!
BTW it was doing the problem (with moz 1.2 and 1.3 series only, 1.0 was working)
with iframe and any other tag that was including some other document into the
page that was being edited... it also was one of the known bugs...
But now it's fixed and works OK!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Summary: Composer will refuse to edit a file with an OBJECT DATA tag → Composer will refuse to edit a file with an OBJECT DATA tag
You need to log in before you can comment on or make changes to this bug.