soundexchange.com - ".cfm" should set content type to text/html

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: rirwin, Unassigned)

Tracking

Details

(Whiteboard: [mimetype][havefix], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Mozilla complains about an "unknown error" when attempting to view pages with
a ".cfm" extension.  As I remember, these are pages produced by "Cold Fusion, or
something, but they should render just like html pages.   Mozilla apparently
doesn't know what to do with them, ie:

http://www.soundexchange.com/soa.cfm




Reproducible: Always

Steps to Reproduce:
1. Go to the sample URL's I have provided
2.
3.

Actual Results:  
Browser produces an "unknown error" message and suggests I save the page

Expected Results:  
Displayed the page (Internet Explorer does correctly display this type of page.)

Comment 1

16 years ago
->File Handling
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: asa → petersen

Comment 2

16 years ago
It's up to the server to send the correct MIME type, shouldn't be
application/octet-stream but text/html indeed.
Assignee: law → susiew
Status: UNCONFIRMED → NEW
Component: File Handling → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Version: Trunk → unspecified

Updated

16 years ago
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: [mimetype][havefix]

Comment 3

16 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Updated

16 years ago
Summary: Browser should interpret pages with ".cfm" extension as text/html → soundexchange.com - ".cfm" should set content type to text/html
(Reporter)

Comment 4

16 years ago
Indeed, soundexchange has misconfigured their server.  
This is not a browser bug.
Thank you for your time.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 5

16 years ago
Er - Evangelism bugs are NEVER browser bugs.  Since I still see the behavour,
the site hasn't yet fixed their server and this bug should remain open until
they do.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 138519 [details]
Screenshot of worksforme

Check this screenshot (PNG format). It renders the page fine (but it looks like
the page has changed).
It works for me just fine. I just tried quite a few pages on that site
(unfortunately wasn't able to get any valid CFM pages). The URL included with
this bug originally seems to return a 404 error on the site. Check my screenshot
for details.

My Mozilla user-agent string (not the latest dev version by far): Mozilla/5.0
(Windows; U; Win98; en-US; rv:1.5) Gecko/20031007 MultiZilla/1.5.0.4h

Updated

15 years ago
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.