[Dogfood][Regression] Today's installer gives an error: -1

VERIFIED FIXED in M12

Status

Core Graveyard
Installer: XPInstall Engine
P1
critical
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: Scott MacGregor, Assigned: Sean Su)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
Running today's windows installer (11/23), german and I both get a dialog
that says "Error: -1" and then the rest of the install aborts.


I get this when we are trying to install overlay.rdf
 so this may be related.

Adding amusil to the cc list because this may relate to some problems I have in
the tasks overlay with his stuff.
(Reporter)

Updated

19 years ago
Priority: P1
Product: Browser
(Reporter)

Comment 1

19 years ago
arggh I created this bug using today's release build and apparently the posting
seems to have not worked. (Hence the blank reporter and assigned to fields). I
don't know how to fix this. Lisa/Jan, do either of you know?

Adding ssu to the cc list since I think he is the moduleowner for xpinstall
which is where I was trying to assign the bug to in the first place.
(Assignee)

Comment 2

19 years ago
what is the filename of the installer that is giving the -1 error?

Updated

19 years ago
Status: REOPENED

Updated

19 years ago
Assignee: __UNKNOWN__ → ssu
Status: REOPENED → NEW

Comment 3

19 years ago
This bug has strange entires for reporter, etc.  I'll attempt to fix.

Comment 4

19 years ago
I don't know how to fix "reporter" - but all other fields are ok for now.
(Reporter)

Comment 5

19 years ago
Thanks for fixing part of this up for me Lisa. I filed Bug #19971 to track
the fact that posting is busted on seamonkey today.

Comment 6

19 years ago
I am also failing install, win95.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

19 years ago
I'm on it.  I'm finally able to get the install to fail, but not with a -1.  I
get a crash in js3250.dll.  I'm looking at it some more.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 8

19 years ago
Putting on PDT+ radar.

Updated

19 years ago
QA Contact: gbush

Comment 9

19 years ago
Setting QA contact.
(Assignee)

Comment 10

19 years ago
*** Bug 19958 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

19 years ago
adding dveditz to the CC list since he is able to reproduce the -1 error on his
system with a debug build.  He's currently looking at it.

FYI: There seems to have been another semi-related bug to this in that depending
on the target system's setup, psm.xpi would crash in js3250.dll.  Some people
have reported this problem.  It has been fixed in the psm.xpi's install.js
script.  The -1 error is still being investigated.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

19 years ago
adding comments from dveditz:
=============================================================================
At sometime in the past I installed a psm that claimed to be
version 5.0.0.99313, while *this* version is 5.0.0.99300 -- a LOWER
version.

InstallFile compares the version and finds that the one to install is
"older" than what I've got and returns the result of that comparison as
an error! A simple addFile()/AddSubcomponent() would return the same
error.

The short term solution is to call the install in FORCE mode so we don't
get bit by whatever version crap is going on in release. Then the files
will always install and this bug won't get us. Even if we didn't have
this bug we still wouldn't get any files installed without the FORCE
flag given the version problems.

Then AddDirectory continues to loop through the files, and only returns
The very last error it got. In this case every file got the same error,...

So what I've done for now is change all the script template files to
use an explicit "true" force mode. That, at least, will work. That's
about all I have time to do before the tree closes and the build kicks
off this morning.

That'll buy time to work on the real structural fix(es).
==========================================================================

I'm marking this fixed.  Please reopen this bug if we need to close only when
the structural fixes are in.
The generic bug for this condition is 20043.  Would occur in any install script
installing an older version and not using "force" mode.

Updated

19 years ago
Severity: normal → critical
Target Milestone: M12

Comment 14

19 years ago
Putting on M12 radar since fixed during this time.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
Seems ok with todays Win 1999-11-29-09-M12/ build.  Marking Verified.

Comment 16

19 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.