The page does not fit on screen horizontally

RESOLVED FIXED

Status

()

Core
Layout: Tables
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Palasik Sandor, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

43.98 KB, application/octet-stream
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

The page body is a 3 column table, and has fixed width of 768 pixels. The left
and right columns also have fixed width, but the middle column does not fit into
the remaining space.


Reproducible: Always

Steps to Reproduce:
1. Just look at the URL

Actual Results:  
I see a page with a horizontal scrollbar.

Expected Results:  
Fit the middle column into the remaining space.

When editing the page with composer, I can fix the problem by changing the table
width of one of the tables from unspecified to 100%.

The affected part changes from:
<table border="0" align="left" cellpadding="10" cellspacing="0">
To:
<table border="0" cellpadding="10" cellspacing="0" style="width: 100%;">
(Reporter)

Comment 1

15 years ago
Created attachment 118701 [details]
test case HTML

There is an original.htm file in the ZIP, and also there is a fixed.htm.
I tried to reduce the difference to one line in the html.

Comment 2

15 years ago
Tested URL above with 1.3 and trunk. Didn´t look at attachment.
Confirming error with 1.3, don´t see the right column without scrolling half the
screen.
Works for me with current nightly:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030327

Comment 3

15 years ago
Reporter could retest with a current nightly, or the 1.4a once it is released.
(Reporter)

Comment 4

15 years ago
Tested with nightly build, it seems fixed.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030327
Thank you :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.