Selecting 'No' from unistall confirmation dialog removes GREUSer applist entry

RESOLVED WONTFIX

Status

Core Graveyard
Installer: GRE
P2
major
RESOLVED WONTFIX
15 years ago
6 years ago

People

(Reporter: Charles Rosendahl, Assigned: Sean Su)

Tracking

({topembed+})

Trunk
x86
Windows 2000
topembed+

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Install GRE installer using defaults
From control panel: add/remove programs, select remove GRE.

Before the Uninstaller even executes, GREUser is removed from the applist and
the entry is removed from the add/remove programs list.

This should be done after the user confirms to proceed with uninstallation, not
before.
(Reporter)

Updated

15 years ago
Severity: normal → major
Priority: -- → P2
Summary: Selecting 'No' from unistall confirmation dialog removes GREUSer applist entry → Selecting 'No' from unistall confirmation dialog removes GREUSer applist entry
(Reporter)

Updated

15 years ago
Keywords: nsbeta1, topembed

Comment 1

15 years ago
Discussed in edt bug triage.  Plussing.
Keywords: topembed → topembed+

Comment 2

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
(Assignee)

Comment 3

15 years ago
The problem is that CleanupAppList() is being called before the prompt is shown.
 The problem is here:
 
http://lxr.mozilla.org/seamonkey/source/xpinstall/wizard/windows/uninstall/extra.c#1965

The fix is to have the above code be done in one of these places (not in all of
them):
 http://lxr.mozilla.org/seamonkey/source/xpinstall/wizard/windows/uninstall/uninstall.c#117
http://lxr.mozilla.org/seamonkey/source/xpinstall/wizard/windows/uninstall/dialogs.c#313
Status: NEW → ASSIGNED
Product: Core → Core Graveyard
The GRE installer is long dead
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.