Closed Bug 19955 Opened 22 years ago Closed 22 years ago

[DOGFOOD] [REGRESSION]News and POP not working in todays builds

Categories

(MailNews Core :: Networking, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mscott, Assigned: mscott)

Details

(Whiteboard: [PDT+])

Using the 11/23 release build from this morning, I can no longer read
newsgroups. I can select a newsgroup and it says downloading headers...but the
thread pane is never populated with the articles.

Sspitzer is on vacation till the end of the week so I'll look into this one
myself.
Severity: normal → critical
QA Contact: lchiang → huang
Not good.
I am thinking this is migration problem since I used yesterday's migration
without this problem.
But today's build with this problem. Scott, Are you using today's migration?
OS: Windows NT → All
Hardware: PC → All
Summary: [DOGFOOD] [REGRESSION]News isn't working in todays builds → [DOGFOOD] [REGRESSION]News and POP not working in todays builds
Additional info using nov23-08 commercial builds (I used linux and mac, can't
launch my win32):

POP mail is not working either and it is suspected to be the same problem as
scott reported for news.

If you use an existing POP account, you can see the headers already downloaded
in previous builds, but cannot get new messages. If you've displayed a folder
(already populated) then switch to another folder, the status bar indicates the
loading is done, but the thread pane remains constant at the display of the
original folder contents.

If you add a new POP account, you can't get messages at all.  Status bar
indicates you've retrieved headers but the thread pane remains blank.

Changed Platform and OS to All, changed summary to reflect POP.
Status: NEW → ASSIGNED
Target Milestone: M12
Turns out this is a backend bug in mailnews and isn't related to migration.
I have a fix for it and pop and news are both working for me again.

I'll land this tonight.
Target Milestone: M12
Oh, and in response to Karen's comments, the news (and POP) problem happens on
new accounts and new profiles created with todays builds.
Whiteboard: [PDT+]
Putting on PDT+ radar.
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
I just checked in the fix for this a little while ago. Pop and News
are now working again.
Verified on migrated pop account & news
Linux 11-24-08-M12 works OK.
WinNT 11-24-09-M12 works OK.
Will verifiy on Mac & new profile later.
Verified on new profile for WinNT - works OK
Verified on new profile for Linux - works OK
Verified on Mac 11-24-10-M12 Mozilla build(no commercial build for Mac today)
Migrated profile:
POP - works OK for read mails and send mail
News - works OK for read news and send to newsgroup

My Mac have problem now, still need to verify on Mac for new profile next
Monday....
Status: RESOLVED → VERIFIED
Verified on the Mac 11-24-10-M12 Mozilla build for new profile:

POP - works OK for read POP mails and send mail
News - works OK for read news and send to newsgroup

Mark as Verified.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.