Change From field (identity) and unable to type more than 1 address

RESOLVED DUPLICATE of bug 163701

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 163701
15 years ago
10 years ago

People

(Reporter: Ninoschka Baca, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Trunk build 2003-03-27: WinMe, Mac 10.1.5

Overview: Change From field (identity) and unable to type more than 1 address
when the first account has 2 Bcc addresses and the second account has no Bcc
addresses associated with it.

Steps to reproduce:
1. Create a profile with 2 accounts
2. In the account settings dialog go to the Copies and Folders panel for the:
a. first account and select the Bcc checkbox and type two addresses
b. second account and make sure that the Bcc checkbox is Not selected
3. In the mail 3pane window select the first account, select the Compose button
and you will see the two addresses Bcced
4. Switch the identities by selecting the From field and selecting the second
account and notice that the address area no longer has the Bcc entries as expected.
5. Type an address and press enter

Actual Results: The address is highlighted and it is impossible to press Enter
to advance to the next line.

Expected Results: The first address should remain and the cursor should be
flashing on the second line waiting for input for the second address.
(Reporter)

Comment 1

15 years ago
Additional Information: The problem seems to only occur when one account has 2
Bccs and the other account has 0.

1st account  2nd account  Results
2 Bccs        0 Bccs      Problem Occurs
2 Bccs        1 Bcc       OK
2 Bccs        2 Bccs      OK
1 Bcc         0 Bccs      OK
1 Bcc         1 Bcc       OK
1 Bcc         2 Bccs      OK

Note: I found this problem while verifying bug# 178328 and may be related to
bug# 193594.
Product: MailNews → Core

Comment 2

13 years ago
Dupe highlights additional problem not pointed out here: sending the message 
with the single allowed address results in a "No recipients" error.

*** This bug has been marked as a duplicate of 163701 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.