"save image" is very very very slow

RESOLVED DUPLICATE of bug 195990

Status

RESOLVED DUPLICATE of bug 195990
16 years ago
14 years ago

People

(Reporter: linuxjim, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20021130

"save image" is very slow - I just timed an attempt to save a small image
(slashdot topic gif) at over 4 minutes. During most of this time, the frame (but
not the content) of the save image file select window stays on the screen,
although the window has been removed from the tasklist applet. Also during most
of this time the "saving image" window has NOT YET appeared on screen. Typically
(but a little subjectively) the time is even worse the FIRST time I try to save
image during a single session, later saves seem to run a little faster (but not
much). This problem has been around since Mozilla 1.0. Note that in the majority
of cases the image exists in Cache, and I can find it with a graphics-browser
and "save" it (drag to a directory) in a matter of seconds. In preferences ->
cache, I have "compare" set to "once per session", and I also note that the
"save" time is often far greater than the amount of time that was needed to
download the image in the first place.

Reproducible: Always

Steps to Reproduce:
1.Locate desired image on screen 
2.Right click, select "save image as"
3.Select desired file name and click "save", then WAIT

Actual Results:  
Frame of "save image" window remained on screen, but window contents was blank,
and window was no longer in tasklist. After several minutes, "Saving" window
appeared. Until save was complete, apparently no window updates were done.
Clicking on a different Mozilla window (for example, mail client) in the
tasklist would cause the window FRAME to change to that new window, but window
content was not updated. Also if I went to a different screen workspace (using
Gnome and Sawfish and 4 workspaces) and returned to workspace with Mozilla, the
frame of the Mozilla window reappeared but window contents was still whatever
was shown in the other workspace.

Expected Results:  
I expected everything to happen MUCH MUCH faster, as noted above to simply copy
a file from Cache to another directory takes only seconds. This is a fairly slow
computer (180mHz, 128M memory, running Red Hat 7.0), but saving the file
shouldn't take far longer than downloading it over a 33.6 dial-up. 

I also note that once the image is fully downloaded and displayed, the "save"
time  seems to be relatively constant, regardless of the size of the image.

Comment 1

16 years ago
At best this is a duplicate of bug 195990, at worst it's INVALID due to the age
of the build you're reporting against.  Please install a recent build and see if
you still get the same behaviour.  (If so, reopen bug 195990.)

*** This bug has been marked as a duplicate of 195990 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Ah - just saw the Mozilla version (1.2.1) so the build date on that branch may
be appropriate (?).  If so, I apologize for the "old build" comment.  But this
still looks like a dupe...
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.