Freeze on dragging message from Sent on server to Sent in Local Folders

RESOLVED EXPIRED

Status

SeaMonkey
MailNews: Message Display
--
critical
RESOLVED EXPIRED
15 years ago
13 years ago

People

(Reporter: James C. Townsend, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; IRIX64 IP30; en-US; rv:1.3b) Gecko/20030220
Build Identifier: Mozilla/5.0 (X11; U; IRIX64 IP30; en-US; rv:1.3b) Gecko/20030220

Tried to drag a group of messages from the server's Sent folder to the Sent
folder in Local Folders; several messages had attachments. Only one message was
moved. Then moved several messages individually with no problem. On trying to
move the next one, the pane sizes in the Mail window flickered and settled with
the left pane too narrow to read. When I tried to resize it, I found that
mozilla had frozen. There was no response to any mouse clicks or key clicks in
either Mail or the Browser. Had to use the Unix kill command and restart mozilla
to send this message. Console window displays this error message:
Gtk-CRITICAL **: file gtkdnd.c: line 621 (gtk_drag_get_data): assertion `widget
!= NULL' failed.

Gtk-CRITICAL **: file gtkdnd.c: line 621 (gtk_drag_get_data): assertion `widget
!= NULL' failed.


Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.




It may be that the bug is in the flickering that sometimes occurs when going
from one message to another, even without drag and drop. This flickering happens
frequently but I hadn't seen it cause a crash before. The flickering seems to be
related to the size of lines in the message or, perhaps, very long words, such
as URLs.

Comment 1

14 years ago
I get this same error in mozilla 1.7rc1 and every version I've tried before it
(several) when using a tablet. It may only be a problem when using a tablet, or
it may be that the problem is simply more easy to trigger with a tablet. 
Sometime in the last 13 months, the problem seems to have moved down two lines
in  gtkdnd.c.

Gtk-CRITICAL **: file gtkdnd.c: line 623 (gtk_drag_get_data): assertion `widget
!= NULL' failed.

I'm not sure how to reproduce this problem. Some users come accross it
frequently, and others not at all. I can only assume it's some small aspect of
the way they use the table that makes it happen. 

This error does not crash mozilla, it simply stops mozilla from receiving any
more input from any source. Keyboard, mouse or tablet. killing mozilla is then
the only choice. 

Comment 2

14 years ago
A potentially related error which I haven't seen as frequently (only once in
fact) is...

Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.