If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

the underline on small text lies too far under the text

REOPENED
Assigned to

Status

()

Core
Layout: Block and Inline
P3
minor
REOPENED
15 years ago
8 years ago

People

(Reporter: Az, Assigned: dbaron)

Tracking

({testcase})

Trunk
mozilla1.7beta
testcase
Points:
---
Bug Flags:
blocking1.7b -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme [patch], URL)

Attachments

(4 attachments, 3 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030312 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030312 Phoenix/0.5

Look at the first post on this sitepoint forum thread by user '95degrees':
http://www.sitepointforums.com/showthread.php?threadid=102089

look closely at the users signature found at the bottom of his post.  As the
text is so small the lines are very close together.  The links are underlined
and they lay ontop of text found below.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Not a Phoenix bug.
-> Mozilla/GFX
Assignee: blaker → kmcclusk
Component: General → GFX
Product: Phoenix → Browser
QA Contact: asa → ian
Whiteboard: dupeme
Version: unspecified → Trunk

Comment 2

15 years ago
Reproduced here. Mozilla 2003032808/WXP SP1
The underlines are only incorrect on the two links in his sig - the links
immediately below are underlined properly.

Comment 3

15 years ago
Look at http://www.joelonsoftware.com/. 
On this page there are languages listed on the left. If you shrink the font with
Ctrl+-, the underline starts behaving badly.

I reproduced this with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla
Firebird/0.6

Comment 4

15 years ago
Created attachment 124757 [details]
Underlined small text behaving badly.

Comment 5

15 years ago
Confirmed:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030604

Looks correct in IE6 but not Mozilla.  Also noticed the text color in the Forum
Jump box at the bottom of the page was black in Mozilla and blue in IE6.
(Reporter)

Comment 6

14 years ago
multiple confirmations, can this be moved to NEW?
Flags: blocking1.7b?
(Reporter)

Comment 7

14 years ago
i am reconfirming, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Comment 8

14 years ago
Seeing this in Firefox 0.8.. 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Confirming Bug...

Is this related to Bug 192379?
Assignee: kmcclusk → general
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

14 years ago
Created attachment 143344 [details]
simplified testcase from joel on software

Looks like this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Joel on Software</title>
</head>
<body>
<p>
<a href="http://brazil.joelonsoftware.com"><font size="1">Brazilian
Portuguese</font></a><br>
<a href="http://bulgarian.joelonsoftware.com"><font
size="1">Bulgarian</font></a><br>
</p>
</body>
</html>

Updated

14 years ago
Assignee: general → dbaron
Keywords: testcase
Created attachment 143346 [details] [diff] [review]
possible patch

I think this bug is the result of the interaction of standards-mode
text-decoration with quirks-mode line box model (i.e., almost-standards mode).

I think this patch is roughly what we need, but I haven't tested it yet...
Severity: trivial → minor
Status: NEW → ASSIGNED
Component: GFX → Layout: Block and Inline
OS: Windows 2000 → All
Priority: -- → P3
Hardware: PC → All
Whiteboard: dupeme → dupeme [patch]
Target Milestone: --- → mozilla1.7beta
Created attachment 143396 [details] [diff] [review]
patch
Attachment #143346 - Attachment is obsolete: true
Created attachment 143398 [details]
additional testcases
Created attachment 143399 [details]
additional testcases

With the patch I'm about to attach I've tested that this does what I expect in
all 3 modes.  (Essentially this patch makes the presence of 'text-decoration'
in almost-standards mode force the inline box model to the full-standards-mode
inline box model for the elements with text-decoration.)
Attachment #143398 - Attachment is obsolete: true
Created attachment 143400 [details] [diff] [review]
patch
Attachment #143396 - Attachment is obsolete: true
Attachment #143400 - Flags: superreview?(bzbarsky)
Attachment #143400 - Flags: review?(bzbarsky)
Comment on attachment 143400 [details] [diff] [review]
patch

Looks reasonable, though I have to admit to not knowing this code as well as
I'd like to review this.... :(
Attachment #143400 - Flags: superreview?(bzbarsky)
Attachment #143400 - Flags: superreview+
Attachment #143400 - Flags: review?(bzbarsky)
Attachment #143400 - Flags: review+
Fix checked in to trunk, 2004-03-09 16:28 -0800.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
I'm going to back this out because I forgot about one issue -- images inside A
elements, which are a major case where this quirk is needed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

14 years ago
minus until a better patch appears.
Flags: blocking1.7b? → blocking1.7b-
Summary: the underline on small text lies to far under the text → the underline on small text lies too far under the text
QA Contact: ian → layout.block-and-inline
You need to log in before you can comment on or make changes to this bug.